Package Details: lightdm-pantheon-greeter 3.0-3

Git Clone URL: https://aur.archlinux.org/lightdm-pantheon-greeter.git (read-only)
Package Base: lightdm-pantheon-greeter
Description: Pantheon greeter for LightDM
Upstream URL: https://launchpad.net/pantheon-greeter
Licenses: GPL
Submitter: M0Rf30
Maintainer: alucryd
Last Packager: alucryd
Votes: 35
Popularity: 0.221160
First Submitted: 2012-12-02 11:04
Last Updated: 2016-10-13 12:43

Latest Comments

gbc921 commented on 2016-11-20 17:33

Just to note that version 2.0.2-2 still works.

To do that I had to:
1. Clone this git: 'git clone https://aur.archlinux.org/lightdm-pantheon-greeter.git/'
2. Go into the folder;
3. Checkout v. 2.0.2-2: 'git checkout 2c0979827'
4. Compile the package as usual: 'makepkg -si'
5. Change greeter settings on lightdm.conf
6. Done!

alucryd commented on 2016-09-14 08:33

Because it's not a dep of the greeter, but of one of its deps, obviously.

f4hy commented on 2016-09-14 06:41

Why is gala-bzr not listed as a dependency then?

alucryd commented on 2016-09-13 12:16

The only bzr package required for this to work is gala-bzr, because there hasn't been any release yet. Stable versions are enough for everything else.

f4hy commented on 2016-09-01 02:58

Issues with building the new version (3.0) seem to come from it now requiring much greater hooks into other pantheon objects, like the wingpanel.

What changed? Is this package going to continue to require more and more of the rest of pantheon? It seems like we are in a bad state if this non dev package requires a few *-bzr packages to be able to install.

wbthomason commented on 2016-08-26 15:40

Yes - that package also seems to be missing dependencies. Installing gala-bzr provided libgala.so for me.

mareke commented on 2016-08-26 07:28

While manually installing wingpanel I am getting "error: target not found: libgala.so".

wbthomason commented on 2016-08-26 04:51

When I separately install the wingpanel package (and its dependencies), I can get lightdm-pantheon-greeter to build successfully. However, other things seem wrong (text which was previously large and white is now small and grey, etc.), though these changes might just be part of the update. It seems that wingpanel should be an explicit dependency of this package. That said, it would be nice if I didn't need all of pantheon desktop installed in order to build this greeter.

AndreaM commented on 2016-08-26 02:37

I tried to rebuild as well and saw the wingpanel message:

==> Starting build()...
-- The C compiler identification is GNU 6.1.1
-- The CXX compiler identification is GNU 6.1.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
-- Checking for modules 'granite;liblightdm-gobject-1>=1.2.1;gdk-x11-3.0;clutter-gtk-1.0;gdk-pixbuf-2.0;gl;wingpanel-2.0'
-- No package 'wingpanel-2.0' found
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:424 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:597 (_pkg_check_modules_internal)
CMakeLists.txt:31 (pkg_check_modules)


-- Configuring incomplete, errors occurred!

wbthomason commented on 2016-08-25 21:26

I get the same error as AndreaM and wespe when I try to rebuild without cleaning first. However, my initial build attempt always fails in build() when cmake is unable to find wingpanel (which is not listed as a dependency of this package). See below. Has anyone encountered this before?

==> Starting build()...
-- The C compiler identification is GNU 6.1.1
-- The CXX compiler identification is GNU 6.1.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
-- Checking for modules 'granite;liblightdm-gobject-1>=1.2.1;gdk-x11-3.0;clutter-gtk-1.0;gdk-pixbuf-2.0;gl;wingpanel-2.0'
-- No package 'wingpanel-2.0' found
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:424 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:597 (_pkg_check_modules_internal)
CMakeLists.txt:31 (pkg_check_modules)

All comments