Package Details: lightly-kf6-git 0.4.1.r73.g00ca234-4

Git Clone URL: https://aur.archlinux.org/lightly-git.git (read-only, click to copy)
Package Base: lightly-git
Description: Modern style for KF6/Qt6 applications
Upstream URL: https://github.com/boehs/lightly
Licenses: GPL-2.0-or-later
Conflicts: lightly-kf6, lightly-qt6, lightly-qt6-git
Provides: lightly-kf6, lightly-qt6, lightly-qt6-git
Submitter: Scrumplex
Maintainer: D3SOX (xiota)
Last Packager: xiota
Votes: 9
Popularity: 0.021804
First Submitted: 2020-08-03 11:07 (UTC)
Last Updated: 2024-04-02 23:46 (UTC)

Latest Comments

1 2 3 Next › Last »

xiota commented on 2024-04-03 12:09 (UTC)

While kf5/6 in the package names is somewhat unusual, naming with qt5/6 might be considered inaccurate because kf5/6 are needed to build and use these packages.

I've commented at the -qt6-git package to notify the maintainer and interested users of changes to this package.

alba4k commented on 2024-04-03 09:30 (UTC) (edited on 2024-04-03 09:31 (UTC) by alba4k)

Well done! Send a deletion request for -qt6 maybe

and then maybe you can ask to rename those to -qt5 and -qt6, which would at least be more intuitive

Maybe talk about it with the maintainer first, as requests sent by maintainers are reviewed with higher priority

xiota commented on 2024-04-02 05:28 (UTC) (edited on 2024-04-02 05:55 (UTC) by xiota)

Converted to a split package. Using -kf# because -qt6 is taken. Did not combine everything to keep KF5 and KF6 depends separate. Let me know if any problems.

alba4k commented on 2024-04-01 22:17 (UTC)

It could even just be a -bin version providing the old theme, already built.

But really, a qt5 package to be installed alongside the qt6 one would be great (now that lightly-git and lightly-qt6-git are no longer the way to go). This should also be considered by upstream, tho.

xiota commented on 2024-04-01 15:02 (UTC)

Arch is moving on to KF6, so building for KF5/Qt5 probably won't work long term.

DexterHaxxor commented on 2024-04-01 14:40 (UTC)

so now we need a lightly-qt5-git and delete the old one

xiota commented on 2024-03-31 22:55 (UTC) (edited on 2024-03-31 22:58 (UTC) by xiota)

I've switched this package to the qt6 branch.