Package Details: limnoria-git 20200131.11218.2f493625-1

Git Clone URL: https://aur.archlinux.org/limnoria-git.git (read-only, click to copy)
Package Base: limnoria-git
Description: An IRC bot based on Supybot, with sqlite3 support and other features (dev channel)
Upstream URL: https://github.com/ProgVal/Limnoria
Licenses: 3-clause BSD
Conflicts: limnoria, limnoria-python3, limnoria-python3-git
Submitter: Cravix
Maintainer: Cravix
Last Packager: Cravix
Votes: 3
Popularity: 0.000000
First Submitted: 2012-01-26 14:18 (UTC)
Last Updated: 2020-03-17 09:19 (UTC)

Dependencies (11)

Required by (0)

Sources (1)

Latest Comments

Cravix commented on 2020-03-17 09:21 (UTC)

Ah sorry for the delay, and now it works again.

Cravix commented on 2020-03-14 15:03 (UTC)

@irb: Ah seems it changed again, I'll update PKGBUILD tomorrow, thanks for the report :)

irb commented on 2020-03-12 17:04 (UTC)

In the pkgver() function, there's a sed line that causes the build to fail:

sed -n '1s/[^[:digit:]]//gp' src/version.py

there is no "version.py" in src/.

Cravix commented on 2020-02-17 05:27 (UTC)

now the merge requests have been accepted, and I've rewrited the pkgbuild,

and after installation, you can safely remove limnoria-python3-git yourself,

or wait for a month (transition period) and I'll remove it in the next update.

Cravix commented on 2020-02-12 09:57 (UTC) (edited on 2020-02-12 10:07 (UTC) by Cravix)

I've submitted merge requests a day ago, and TUs haven't fulfilled them, so I guess it's better to write my solution here first (PKGBUILD has been rewrited indeed):

E.g. for limnoria-git & limnoria-python3-git, I make a package base named limnoria-git to build both package, where limnoria-git contains all the data file, and limnoria-python3-git is just an empty package that make it easier for previous users to upgrade using aur managers.

And after the period of transition (a month is enough I guess), I'll push the second version that only build limnoria-git, and also put limnoria-python3-git into "replaces" array, to safely remove it.

Cravix commented on 2020-02-11 07:49 (UTC) (edited on 2020-02-11 07:51 (UTC) by Cravix)

@sanerb:

thanks for the notice :)

to be exact I have 2 limnoria packages that work with python 2 and 3 (limnoria-python3 to be exact),

so now I need to find a way to make it easier for users of another package to migrate,

I'll deal with it in a day or 2 I guess, hmm

sanerb commented on 2020-02-09 17:16 (UTC)

limnoria now no longer supports python2. Please modify the PKGBUILD to build with python3.

Cravix commented on 2018-08-15 13:29 (UTC)

@irb ok, fixed, thanks for your report :)

irb commented on 2018-07-18 17:51 (UTC) (edited on 2018-08-08 16:18 (UTC) by irb)

This package installs with the version string "%s.10974.0d627c05-1" which I don't think is right, since it says it's going to install "0.83.4.1.10347.530c246-1". Perhaps some automation gone awry?

Note: It's not the version itself but the "%s" in the version that I'm curious about.

Cravix commented on 2015-03-10 00:59 (UTC)

@Beini: patch applied, Thanks bro :)

Beini commented on 2015-03-03 23:05 (UTC)

Build fails because 'docs' directory has been removed: https://github.com/ProgVal/Limnoria/commit/0b9e54ebcf2dbc80098fdb5ed3b5d872b5359c18 Here's the fix for the PKGBUILD: https://gist.github.com/Ban3/954b11ce8e2d61f4779f

commented on 2012-12-18 07:06 (UTC)

Never mind. It seems to have been already fixed. I had to remove limnoria update then reinstall limnoria.

commented on 2012-12-18 06:39 (UTC)

Ya, not sure what the prob was. It's working now. Is there any way to fix this? :: python2-pysqlite and python-pysqlite are in conflict. Remove python-pysqlite? [y/N] Y error: failed to prepare transaction (could not satisfy dependencies) :: limnoria-git: requires python-pysqlite

Cravix commented on 2012-12-16 05:59 (UTC)

@LinuxFTW: cannot reproduce, the pkgbuild works for me, and there's no curl call in script, did this error occur when installing dependency?

commented on 2012-12-15 19:45 (UTC)

I am getting this error: curl: (3) <url> malformed

Cravix commented on 2012-06-11 13:41 (UTC)

BTW, i'll change the pkgver to normal one later~

Cravix commented on 2012-06-11 13:38 (UTC)

sorry for my mistake- i wrote the wrong version(20120401*2*) before :( now i adjust the pkgbuild to make it automatically detect the version and take it as the pkgver, in addition, i change the pkgver to 20120611*0* to make it bigger than 20120401*2* to remind those who have installed it to upgrade package, and it doesn't matter since pkgver will be adjusted when you install it :)

Cravix commented on 2012-03-03 09:20 (UTC)

oh, another thing to say, actually twisted is optdep, limnoria uses socket by default. if anyone wants to use twisted instead, please use "config drivers.module twisted" to set it.