Package Details: linkchecker 9.4-1

Git Clone URL: https://aur.archlinux.org/linkchecker.git (read-only)
Package Base: linkchecker
Description: An command line utility to check HTML documents for broken links.
Upstream URL: https://github.com/linkcheck/linkchecker
Licenses: GPL
Submitter: None
Maintainer: masser
Last Packager: masser
Votes: 26
Popularity: 0.000443
First Submitted: 2005-11-09 05:36
Last Updated: 2017-03-30 12:39

Latest Comments

masser commented on 2017-03-30 13:07

2agrim

The project was divided into two parts:
1. linkchecker (Command line version)
2. linkchecker-gui (GUI version)

In AUR present both versions.
https://aur.archlinux.org/packages/linkchecker/
https://aur.archlinux.org/packages/linkchecker-gui/

agrim commented on 2017-03-26 12:10

According to this bug
https://github.com/wummel/linkchecker/issues/708

the project moved to
https://github.com/linkcheck/linkchecker

Any chance to get an updated version?

thanks

electricprism commented on 2016-12-09 00:08

The Icon listed in the desktop launcher is a bad link, could you add a patch to correct the link?

I've noted the problem over here:
https://github.com/wummel/linkchecker/issues/695

michalzuber commented on 2016-07-05 06:41

Made a patch for the package https://gist.github.com/mikaelz/7477f9ad5628157e1a371900776b26c1
Thanks @Sathors for the solution

Sathors commented on 2016-06-10 16:29

@e-anima, the bug is resolved in this pull request: https://github.com/wummel/linkchecker/pull/650.

The problem is that it is not yet merged, and it does not seem it will get merged soon.

I used the code from the pull request to create a patch, to add to the PKGBUILD, and resolve the problem until the pull request gets merged.
Actually the pull request itself is not working as a patch, because of a one character difference (the "if requests.__version__ <" has to be "if requests.__version__ <=").

The patch is
```
diff --git a/linkcheck/__init__.py b/linkcheck/__init__.py
index 22a0cf5..219e576 100644
--- a/linkcheck/__init__.py
+++ b/linkcheck/__init__.py
@@ -20,13 +20,14 @@

# version checks
import sys
+from distutils.version import LooseVersion
# Needs Python >= 2.7 because we use dictionary based logging config
# Needs Python >= 2.7.2 which fixed http://bugs.python.org/issue11467
if not (hasattr(sys, 'version_info') or
sys.version_info < (2, 7, 2, 'final', 0)):
raise SystemExit("This program requires Python 2.7.2 or later.")
import requests
-if requests.__version__ <= '2.2.0':
+if LooseVersion(requests.__version__) < LooseVersion('2.2.0'):
raise SystemExit("This program requires Python requests 2.2.0 or later.")

import os
```

e-anima commented on 2016-05-18 09:45

wehn trying to launch from the console: This program requires Python requests 2.2.0 or later.

masser commented on 2014-04-13 04:14

2OliK
fixed

OliK commented on 2014-04-10 12:59

The gui version (linkchecker-gui) depends on extra/python2-pyqt4.

masser commented on 2014-03-27 06:00

2Chrissss
Try to install the module python2-requests

Chrissss commented on 2014-03-26 14:03

I get this error...

$ linkchecker
Traceback (most recent call last):
File "/usr/bin/linkchecker", line 34, in <module>
from linkcheck.cmdline import print_version, print_usage, aggregate_url, \
File "/usr/lib/python2.7/site-packages/linkcheck/cmdline.py", line 23, in <module>
from . import checker, fileutil, strformat, plugins
File "/usr/lib/python2.7/site-packages/linkcheck/checker/__init__.py", line 24, in <module>
from .. import strformat, url as urlutil, log, LOG_CHECK
File "/usr/lib/python2.7/site-packages/linkcheck/url.py", line 25, in <module>
import requests
ImportError: No module named requests

All comments