Package Details: linkchecker 9.3-2

Git Clone URL: https://aur.archlinux.org/linkchecker.git (read-only)
Package Base: linkchecker
Description: An utility to check HTML documents for broken links.
Upstream URL: http://wummel.github.io/linkchecker/
Licenses: GPL
Submitter: None
Maintainer: masser
Last Packager: masser
Votes: 26
Popularity: 0.102485
First Submitted: 2005-11-09 05:36
Last Updated: 2016-07-08 15:57

Dependencies (5)

Required by (0)

Sources (2)

Latest Comments

michalzuber commented on 2016-07-05 06:41

Made a patch for the package https://gist.github.com/mikaelz/7477f9ad5628157e1a371900776b26c1
Thanks @Sathors for the solution

Sathors commented on 2016-06-10 16:29

@e-anima, the bug is resolved in this pull request: https://github.com/wummel/linkchecker/pull/650.

The problem is that it is not yet merged, and it does not seem it will get merged soon.

I used the code from the pull request to create a patch, to add to the PKGBUILD, and resolve the problem until the pull request gets merged.
Actually the pull request itself is not working as a patch, because of a one character difference (the "if requests.__version__ <" has to be "if requests.__version__ <=").

The patch is
```
diff --git a/linkcheck/__init__.py b/linkcheck/__init__.py
index 22a0cf5..219e576 100644
--- a/linkcheck/__init__.py
+++ b/linkcheck/__init__.py
@@ -20,13 +20,14 @@

# version checks
import sys
+from distutils.version import LooseVersion
# Needs Python >= 2.7 because we use dictionary based logging config
# Needs Python >= 2.7.2 which fixed http://bugs.python.org/issue11467
if not (hasattr(sys, 'version_info') or
sys.version_info < (2, 7, 2, 'final', 0)):
raise SystemExit("This program requires Python 2.7.2 or later.")
import requests
-if requests.__version__ <= '2.2.0':
+if LooseVersion(requests.__version__) < LooseVersion('2.2.0'):
raise SystemExit("This program requires Python requests 2.2.0 or later.")

import os
```

e-anima commented on 2016-05-18 09:45

wehn trying to launch from the console: This program requires Python requests 2.2.0 or later.

masser commented on 2014-04-13 04:14

2OliK
fixed

OliK commented on 2014-04-10 12:59

The gui version (linkchecker-gui) depends on extra/python2-pyqt4.

masser commented on 2014-03-27 06:00

2Chrissss
Try to install the module python2-requests

Chrissss commented on 2014-03-26 14:03

I get this error...

$ linkchecker
Traceback (most recent call last):
File "/usr/bin/linkchecker", line 34, in <module>
from linkcheck.cmdline import print_version, print_usage, aggregate_url, \
File "/usr/lib/python2.7/site-packages/linkcheck/cmdline.py", line 23, in <module>
from . import checker, fileutil, strformat, plugins
File "/usr/lib/python2.7/site-packages/linkcheck/checker/__init__.py", line 24, in <module>
from .. import strformat, url as urlutil, log, LOG_CHECK
File "/usr/lib/python2.7/site-packages/linkcheck/url.py", line 25, in <module>
import requests
ImportError: No module named requests

lp76 commented on 2012-08-25 13:05

Updated to 7.9

lp76 commented on 2012-05-17 11:44

Updated to 7.8

lp76 commented on 2012-04-09 06:03

Updated to 7.6

qubodup commented on 2012-02-28 16:36

Same problem as selig's here.
Had to remove python-dnspython to allow it to install.

qubodup commented on 2012-02-28 16:35

Same problem as selig's here.

dkorzhevin commented on 2012-01-24 17:21

Doesn't works

lp76 commented on 2011-11-23 07:04

Updated to version 0.7.2

lp76 commented on 2011-11-23 07:04

Updated to versione 0.7.2

Anonymous comment on 2011-08-11 15:31

error: failed to commit transaction (conflicting files)
linkchecker: /usr/lib/python2.7/site-packages/dns/__init__.py exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/__init__.pyc exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/dnssec.py exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/dnssec.pyc exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/e164.py exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/e164.pyc exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/edns.py exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/edns.pyc exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/entropy.py exists in filesystem
linkchecker: /usr/lib/python2.7/site-packages/dns/entropy.pyc exists in filesystem
......
For ex. /usr/lib/python2.7/site-packages/dns/tsig.py is owned by python-dnspython 1.9.2-1

:: namebench: requires python-dnspython

lp76 commented on 2011-05-29 05:30

New version 7.0

lp76 commented on 2011-05-22 07:41

Updated to 6.9
Thanks Dragonlord!

Dragonlord commented on 2011-05-15 13:30

http://pastebin.com/PeSEif4d

lp76 commented on 2011-04-25 12:47

New version 6.7

lp76 commented on 2011-04-09 06:09

New version 6.6
Thanks CPUnltd

CPUnltd commented on 2011-04-09 03:49

version 6.6 is now out...

lp76 commented on 2011-03-13 09:17

New version 6.5

lp76 commented on 2011-03-08 06:53

Updated to 6.4

lp76 commented on 2011-02-02 07:02

Updated to version 6.2

lp76 commented on 2010-11-26 07:10

Updated to 5.5
Thanks mikyter

Anonymous comment on 2010-11-22 19:08

And 5.5 is there.
You only need to change the version and checksum...

lp76 commented on 2010-11-05 06:56

Updated to 5.4
Thanks Mikyter

Anonymous comment on 2010-11-02 17:35

5.4 is out...

lp76 commented on 2010-10-23 06:36

Updated dependencies

lp76 commented on 2010-10-10 06:47

Updated to 5.3
Thank you mikyter

Anonymous comment on 2010-10-08 18:03

LinkChecker 5.3 is available!
The updated PKGBUILD: http://aur.pastebin.com/zz2XpZqG

lp76 commented on 2010-04-06 05:44

Added x86_64 tag. Thanks to Paterbrown

paterbrown commented on 2010-04-05 09:19

Can you add x86_64? I have tested, it works...

lp76 commented on 2010-04-05 06:33

Updated to version 5.2