Package Details: linkerd 2.7.0-0

Git Clone URL: https://aur.archlinux.org/linkerd.git (read-only, click to copy)
Package Base: linkerd
Description: A service sidecar for Kubernetes and beyond. Main repo for Linkerd 2.x. - https://linkerd.io
Upstream URL: https://linkerd.io/2/getting-started/
Licenses: Apache
Submitter: eldios
Maintainer: eldios
Last Packager: eldios
Votes: 3
Popularity: 0.093098
First Submitted: 2018-09-18 21:05
Last Updated: 2020-02-29 00:10

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

semyon95 commented on 2020-02-28 21:04

I believe this package should have a "-bin" suffix in the name. Packages without such suffix are expected to build the binary from source instead of installing a prebuilt one

eldios commented on 2020-01-28 17:56

updated to 2.6.1

kaosaur commented on 2020-01-28 17:23

diff --git a/.SRCINFO b/.SRCINFO index b0c07ad..847e52b 100644 --- a/.SRCINFO +++ b/.SRCINFO @@ -1,14 +1,14 @@ pkgbase = linkerd pkgdesc = A service sidecar for Kubernetes and beyond. Main repo for Linkerd 2.x. - https://linkerd.io - pkgver = 2.6.0 + pkgver = 2.6.1 pkgrel = 0 url = https://linkerd.io/2/getting-started/ arch = x86_64 license = Apache depends = glibc options = !strip - source_x86_64 = linkerd::https://github.com/linkerd/linkerd2/releases/download/stable-2.6.0/linkerd2-cli-stable-2.6.0-linux - sha256sums_x86_64 = 87103cda7038950e90ebba9de072f7a787ee9e9efc8066561c456f404625d7c3 + source_x86_64 = linkerd::https://github.com/linkerd/linkerd2/releases/download/stable-2.6.1/linkerd2-cli-stable-2.6.1-linux + sha256sums_x86_64 = 91f9cee0d4d040df25f05e685d6b581bc207525944e37f3aaa453e846072da88

pkgname = linkerd

diff --git a/PKGBUILD b/PKGBUILD index 115eafd..978f196 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -1,7 +1,7 @@ # Maintainer: Emanuele 'Lele aka eldios' Calo' xeldiosx@gmail.com

pkgname=linkerd -pkgver=2.6.0 +pkgver=2.6.1 pkgrel=0 pkgdesc="A service sidecar for Kubernetes and beyond. Main repo for Linkerd 2.x. - https://linkerd.io" arch=('x86_64') @@ -12,7 +12,7 @@ source_x86_64=( "linkerd::https://github.com/linkerd/linkerd2/releases/download/stable-${pkgver}/linkerd2-cli-stable-${pkgver}-linux" ) sha256sums_x86_64=( - '87103cda7038950e90ebba9de072f7a787ee9e9efc8066561c456f404625d7c3' + '91f9cee0d4d040df25f05e685d6b581bc207525944e37f3aaa453e846072da88' ) options=(!strip)

eldios commented on 2019-10-16 13:59

updated to 2.6.0

apaatsio commented on 2019-10-16 11:12

2.5.0 was released Aug 21 and 2.6.0 was released Oct 10. This package is still hanging onto 2.4.0. What's the status?

eldios commented on 2019-09-17 16:23

interesting, didn't know about this. Thanks for pointing this out @dangersalad

Will fix that in the next release.

dangersalad commented on 2019-09-17 16:13

Of note: In general I think the pkgrel is usually set to 1 for the first version, not 0

adsun commented on 2019-06-05 16:52

Checksums should be updated. Everytime there is a new release, the checksums need to change accordingly.

eldios commented on 2019-05-13 17:33

Checksum fixed.

adsun commented on 2019-05-13 17:26

Checksums should be updated.