Package Details: linode-cli 5.21.0-1

Git Clone URL: https://aur.archlinux.org/linode-cli.git (read-only, click to copy)
Package Base: linode-cli
Description: Linode API wrapper
Upstream URL: https://github.com/linode/linode-cli
Keywords: cli python
Licenses: BSD
Replaces: linode-cli-dev
Submitter: slithery
Maintainer: morgenstern
Last Packager: morgenstern
Votes: 10
Popularity: 0.78
First Submitted: 2015-08-12 20:52 (UTC)
Last Updated: 2022-06-30 17:13 (UTC)

Pinned Comments

morgenstern commented on 2021-02-06 22:37 (UTC)

As of version 3.2.1.20201118-4, this package has been updated to the enum34 commit and patched to eliminate any Python 2 dependencies.

Latest Comments

morgenstern commented on 2022-06-20 06:12 (UTC)

Thanks @milas, this has now been fixed, apologies for the delay.

milas commented on 2022-06-17 15:13 (UTC) (edited on 2022-06-17 15:14 (UTC) by milas)

It looks like 5.20.0 got re-tagged upstream 3 days ago and install is failing due to mismatched sha512 for linode-cli-5.20.0.tar.gz.

In the PKGBUILD currently:

1448156a354aed11b8256ea1feae3c3202f6976310df4be60c3018fcccd9df68f41267683fbf978886e1a6ff5e2e008d71c8784a9a8af915c23d39d5f935662e

Run in terminal just now:

$ curl -sSL https://github.com/linode/linode-cli/archive/refs/tags/5.20.0.tar.gz | sha512sum                                      
e149d7625dbc7ecf49468754a1a4f2a8f14090b7a3675566d8acf8ca1e88b5da624fb6bb07e84c7a4be2949b8a5d8fe9d37ba8983e9adc5834eec6bb841e4592

the-k commented on 2022-01-30 23:32 (UTC)

BTW, another option is to just use the wheel package from PyPI according to https://wiki.archlinux.org/title/Python_package_guidelines#Source. This way, we wouldn't have to patch anything, including Makefile.

morgenstern commented on 2022-01-30 23:17 (UTC) (edited on 2022-01-30 23:31 (UTC) by morgenstern)

@the-k agreed, I will see what I can do in the interim.

EDIT - I have pushed an updated PKGBUILD that includes your sed command to patch setup.py. Let me know if that causes any issues. Thanks for the help.

the-k commented on 2022-01-30 23:10 (UTC)

@morgenstern I agree with you, but until it's fixed upstream, we might wanna implement one of my suggestions. Perhaps we can patch setup.py directly with something like sed -i "s/\(version=\)get_version()/\1'${pkgver}'/" setup.py in prepare(). It's very easy to add or remove and it's not blocked by the upstream.

morgenstern commented on 2022-01-30 20:17 (UTC)

@the-k if upstream is going to release tagged versions, then in my opinion they should fix their code that handles the version string so that it is independent of the git repository. I will open an issue upstream when I have the time.

the-k commented on 2022-01-30 09:39 (UTC) (edited on 2022-01-30 09:40 (UTC) by the-k)

The package version is broken as it says fatal.-.N.o instead of 5.15.0. This is likely due to https://github.com/linode/linode-cli/blob/db1c3793c14e208da919ed4fa591daf2cc68c434/version, which expects to be run in the Git repository. Therefore, this package should either switch to using the Git repository or patch the script to simply print the version from ${pkgver}.

morgenstern commented on 2021-05-09 04:54 (UTC)

Fixed, thanks @nogweii.

nogweii commented on 2021-05-09 04:42 (UTC)

@morgenstern there is an unspecified make dependency on python-setuptools. Attempting to build this package in a clean container/chroot after the update to 5.2.0 results in a "ModuleNotFoundError: No module named 'pkg_resources'" error. That module is provided by python-setuptools, which is commonly pulled in as a dependency on one way or another, so it's not surprising it was missed. :)

morgenstern commented on 2021-02-27 23:58 (UTC)

@krathalan thanks, fixed.

krathalan commented on 2021-02-27 23:28 (UTC)

The upstream URL should be https://github.com/linode/linode-cli. Notice the Github user has changed from "linode-cli" to just "linode". Your source=() array seems to fix this but $url doesn't.

Thanks for the great PKGBUILD.

morgenstern commented on 2021-02-06 22:37 (UTC)

As of version 3.2.1.20201118-4, this package has been updated to the enum34 commit and patched to eliminate any Python 2 dependencies.

morgenstern commented on 2020-12-17 22:07 (UTC)

Right on - will probably look to modify this package in the new year so that it builds from the enum34 commit and also just builds Python 3, as this is literally the last package on my system that "requires" Python 2. :p

alex19EP commented on 2020-12-17 21:49 (UTC)

hay @morgenstern. glad you noticed. in fact, I created that package because I didn't succeed compiling this one, and because I just love the vcs versions and don't like python2.

morgenstern commented on 2020-12-17 21:12 (UTC) (edited on 2020-12-17 21:13 (UTC) by morgenstern)

Hey everyone, alex19EP has written a git version of this package that dispenses with Python 2 and also includes this commit that eliminates the need for my downstream enum34 patch.

Go check it out for a more bleeding edge experience.

nitsky commented on 2020-03-26 00:44 (UTC)

@alex19EP I missed that on the wiki, sorry for bothering. I had previously installed fakeroot and a few others manually. Haha.

alex19EP commented on 2020-03-25 15:09 (UTC)

@nitsky patch is in base-devel group so. you have to install it for building pkges from aur.

nitsky commented on 2020-03-25 14:52 (UTC)

This package failed to build for me because I had not installed core/patch on my system. I believe it should be added as a dependency.

morgenstern commented on 2020-03-16 23:29 (UTC)

@canton7 - I've removed the checkdepends for python2-terminaltables to remove the dependency on python2-termcolor. This issue should be resolved now.

canton7 commented on 2020-02-26 20:36 (UTC)

(There is a problem in that the dependency python2-terminaltables depends on python2-termcolor-git, which tries to use a github repo which is no longer available. That's not this package's fault, but does mean that it can't be built)

canton7 commented on 2020-02-26 20:26 (UTC)

@morgenstern Looks like it's a problem with yay, or possibly my system: it works on another PC. Apologies for the noise!

morgenstern commented on 2020-02-25 22:52 (UTC)

@canton7 I'm not sure what you mean. python2-colorclass is packaged for the AUR and its upstream source is still available.

Can you provide the actual build error you're getting please?

canton7 commented on 2020-02-25 19:55 (UTC)

Looks like python2-colorclass has been removed, so this no longer builds, unfortunately.

morgenstern commented on 2019-07-11 11:38 (UTC)

PKGBUILD has been updated.

morgenstern commented on 2019-06-27 23:58 (UTC)

This is a few versions behind currently, PKGBUILD update coming soon. Apologies for the delay.

morgenstern commented on 2019-04-07 23:30 (UTC)

python2-terminaltables was dropped from the official repos as part of the python2 module removal project (https://www.archlinux.org/todo/die-python2-die/). I have re-packaged it for the AUR and this package builds successfully with it.

python2-colorclass will likely be dropped from the official repos at some point as well, as it is on the removal list. I will try and get it packaged for the AUR as well once that happens.

morgenstern commented on 2019-03-25 02:43 (UTC) (edited on 2019-03-25 02:52 (UTC) by morgenstern)

Package has been updated. Couple of notes:

1) Building the package from source currently requires both python2 and python. This will hopefully be avoided in the future if the Makefile is fixed upstream as promised (https://github.com/linode/linode-cli/issues/78). Once in place, I'll probably just package this for python assuming it will build/install cleanly.

2) enum34 dependency for python is fixed via patch currently, as enum34 is not compatible with python>=3.4. There is also a request to fix this upstream already (https://github.com/linode/linode-cli/issues/29). Once complete, that should hopefully make the patch unnecessary.

alexandria commented on 2019-02-16 01:50 (UTC)

Hey, are you still maintaining this? Looks like it hasn't been updated for a long time.