Package Details: linphone-git 3.12.0.r273.g20efb4ad4-1

Git Clone URL: https://aur.archlinux.org/linphone-git.git (read-only)
Package Base: linphone-git
Description: A Voice-over-IP phone
Upstream URL: http://www.linphone.org
Licenses: GPL
Conflicts: linphone
Provides: linphone
Submitter: vnoel
Maintainer: thrasibule
Last Packager: thrasibule
Votes: 9
Popularity: 0.209580
First Submitted: 2010-10-17 12:07
Last Updated: 2017-12-02 15:41

Latest Comments

thrasibule commented on 2017-10-18 17:29

Yes you can try to install graphviz. I'll add the dependency to the PKGBUILD.

frealgagu commented on 2017-10-18 14:17

I'm obtaining the following:
CMake Error at coreapi/help/doc/doxygen/CMakeLists.txt:43 (message):
The dot program is needed to generate the linphone documentation. You can
get it from http://www.graphviz.org/.
-- Configuring incomplete, errors occurred!

Should I add some missing dependency?
I have doxygen installed (I've even tried the doxygen-git alternative).

thrasibule commented on 2017-10-16 23:59

@frealgagu latest PKGBUILD should build fine, let me know if this doesn't work.

frealgagu commented on 2017-10-16 18:49

I'm having the following error compiling:

/home/frealgagu/.cache/pacaur/linphone-git/src/linphone/tools/test_ecc.c:62:2: warning: ‘linphone_core_destroy’ is deprecated [-Wdeprecated-declarations]
linphone_core_destroy(lc);
^~~~~~~~~~~~~~~~~~~~~
In file included from /home/frealgagu/.cache/pacaur/linphone-git/src/linphone/tools/test_ecc.c:21:0:
/home/frealgagu/.cache/pacaur/linphone-git/src/linphone/include/linphone/core.h:3989:42: note: declared here
LINPHONE_DEPRECATED LINPHONE_PUBLIC void linphone_core_destroy(LinphoneCore *lc);
^~~~~~~~~~~~~~~~~~~~~
[ 97%] Linking C executable lp-test-ecc
[ 97%] Built target lp-test-ecc
make[2]: *** No rule to make target 'coreapi/help/doc/doxygen/xml/index.xml', needed by 'wrappers/cpp/include/linphone++/linphone.hh'. Stop.
make[1]: *** [CMakeFiles/Makefile2:1126: wrappers/cpp/CMakeFiles/linphone++.dir/all] Error 2
make: *** [Makefile:152: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build linphone-git package(s)

Any ideas?

MountainX commented on 2016-07-12 22:49

please add dependencies for bctoolbox and bcunit, etc.

https://github.com/BelledonneCommunications

petterk commented on 2016-07-11 08:05

dependency bctoolbox does not exist.

vnoel commented on 2014-03-01 09:45

ouuuh, this had been a long time, do anybody want to take over the management of this package? I'm leaving it, because I don't use it and don't have the time to take care of it :)

lockheed commented on 2014-02-27 10:58

Compilation fails as it requires a non-existent belle-sip package.

vnoel commented on 2011-10-24 14:24

Done,

Normally the switch should be smooth even if a local copy is already present.

vnoel commented on 2011-10-24 14:14

Thanks, I'm going to update it :)

All comments