Package Details: linphone 3.12.0-1

Git Clone URL: https://aur.archlinux.org/linphone.git (read-only)
Package Base: linphone
Description: A Voice-over-IP phone
Upstream URL: http://www.linphone.org
Licenses: GPL
Submitter: Barthalion
Maintainer: ohmysql
Last Packager: Barthalion
Votes: 20
Popularity: 0.840729
First Submitted: 2018-01-07 17:31
Last Updated: 2018-01-07 17:31

Latest Comments

1 2 Next › Last »

sgar commented on 2019-02-27 18:32

would it be possible to trigger a rebuild/release as this package also depends on core/readline, and if it was build with v7.X.X, linphonec will fail with the message: linphonec: error while loading shared libraries: libreadline.so.7

the newest readline v8.X.X, updated on 10.01.19, is in the core repository and a simple rebuild would solve this issue

GermanG commented on 2019-02-15 08:22

@Vamp898 I'm using linphone and adding accounts without issues, but yes, it sucks when you don't add an account the linphone-proper way and it just silently fails. Maybe the wizard can help you with that.

Vamp898 commented on 2018-11-04 10:12

Anyone noticed yet that this vesion is broken?

Tested on several machines, it is not possible to add an account. Either this package is missing an dependency (using on KDE) or something else is broking, but whatever you get installing this package, is broken

ohmysql commented on 2018-10-12 04:21

@TheDarkula, this compiles fine for me.

ohmysql commented on 2018-10-12 04:09

@ubone @thebodzio you're confusing linphone (the libraries) with linphone-desktop

ohmysql commented on 2018-09-22 23:08

Hi Derlaff, looking at OpenSuse's version, it looks like 3.12 to me. Hi TheDarkula, arg, been struggling to update this dang thing all day. My apologies but I think there's a version number conflict in mediastreamer2 that I'm not able to resolve.

TheDarkula commented on 2018-08-29 04:23

Being that mbedtls has been updated, this no longer compiles.

Relevant errors: /usr/bin/ld: warning: libmbedtls.so.10, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../lib/libbctoolbox.so, not found (try using -rpath or -rpath-link)

/usr/bin/ld: warning: libmbedcrypto.so.1, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../lib/libbctoolbox.so, not found (try using -rpath or -rpath-link)

Current library paths pacman -Ql mbedtls | rg so mbedtls /usr/include/mbedtls/net_sockets.h mbedtls /usr/lib/libmbedcrypto.so mbedtls /usr/lib/libmbedcrypto.so.3 mbedtls /usr/lib/libmbedtls.so mbedtls /usr/lib/libmbedtls.so.11 mbedtls /usr/lib/libmbedx509.so mbedtls /usr/lib/libmbedx509.so.0

derlafff commented on 2018-08-16 16:15

@ohmysql, hi, did you know that the openSUSE maintainer has packaged Linphone 4.x in a fully working way?

Basically, the Qt interface is now in a separate linphoneqt tarball (linphone-desktop repository) that requires all the other components to be built with CMake. Also the released 4.1.1 version lacks certain fixes for Qt 5.10+ without which the whole thing will crash. Hope this helps.

The packages reside in https://build.opensuse.org/project/show/network:telephony https://build.opensuse.org/package/show/network:telephony/linphone

ubone commented on 2018-07-02 11:08

this?

https://github.com/BelledonneCommunications/linphone-desktop/releases/tag/4.1.1

ohmysql commented on 2018-06-08 17:40

I'm happy to update this if someone can show me where the stable version of 4.1 is housed for linux. I don't see it on the website. The previous package found it here:

https://github.com/BelledonneCommunications/linphone/archive/$pkgver.tar.gz")

https://github.com/BelledonneCommunications/linphone/archive/4.1.0.tar.gz is a 404 not found.

I see that linphone has moved to linphone-desktop on GitHub but that doesn't really answer my question about how to get a stable release version for Linux. @thebodzio