Package Details: linux-amd-staging-drm-next-git-headers 4.14.708912.85d09ce5e503-1

Git Clone URL: https://aur.archlinux.org/linux-amd-staging-drm-next-git.git (read-only)
Package Base: linux-amd-staging-drm-next-git
Description: Header files and scripts for building modules for Linux kernel with AMDGPU DC patches
Upstream URL: https://cgit.freedesktop.org/~agd5f/linux/
Keywords: amd amdgpu dal dc radeon vega
Licenses: GPL2
Provides: linux-headers
Submitter: yurikoles
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 5
Popularity: 3.037879
First Submitted: 2017-08-24 18:09
Last Updated: 2017-11-18 19:40

Dependencies (7)

Required by (275)

Sources (4)

Pinned Comments

yurikoles commented on 2017-09-25 18:29

Pull-requests are welcome: https://github.com/yurikoles/linux-amd-staging-drm-next-git

Latest Comments

Joch commented on 2017-11-16 10:59

Hello, thanks a lot for this paket. I got my Vega 64 running and get the graphical interface with xorg running. I think I had to do

mkinitcpio -p linux-amd-staging-drm-next-git

manually. But this is just fine. If I want to add openCL support to my Vega 64 I have to add the ROCm stuff to your solution or did I get something wrong?
Have someone any hints about that or resolved this issue already?

First I tried to build the ROCm kernel without linux-amd-staging-drm-next-git but this ends with an black screen and kernel crash.

So I am grateful for any hints.

LeJimster commented on 2017-11-05 20:39

@laichiaheng - just build&install linux-amd-staging-drm-next-git and the headers/docs will get installed afterwards. I made the same mistake selecting all 3 packages and it will clone and build the entire kernel 3 times, lol.

BTW, Not sure if it's just me being stupid and doing something wrong. But I got an error after it had finished compiling:

"==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linuxlinux-amd-staging-drm-next-git.preset' error: command failed to execute correctly"

However, the preset *was* there when I checked, so I ran:

mkinitcpio -p linux-amd-staging-drm-next-git

and it installed all ok.

laichiaheng commented on 2017-10-31 03:35

Do i need to install linux-amd-staging-drm-next-git-header it if I want to install linux-amd-staging-drm-next-git or just need to it alone?

HellishINC commented on 2017-10-17 20:53

==> Validating source files with sha256sums...
config.x86_64 ... FAILED
==> ERROR: One or more files did not pass the validity check!
:: failed to verify linux-amd-staging-drm-next-git

setting it to 'SKIP' allows it to successfully build but fails to install though it will install via pacman -U.

Strunkenbold commented on 2017-10-05 09:08

@bradmccormack100

np, thx for fixing that.

bradmccormack100 commented on 2017-10-04 22:56

https://github.com/yurikoles/linux-amd-staging-drm-next-git/pull/2 that should resolve it.

bradmccormack100 commented on 2017-10-04 22:38

@Strunkenbold - I'm responsible for bumping this to 4.15 (indirectly)

I was after some feedback from yurikoles for my changes https://github.com/bradmccormack/linux-amd-staging-drm-next-git/commit/97a1cf7ca577a4dc30adbd1adf5f86442e9ba559 but he ended up creating a PR and merging it.

I've even left some comments about my confusion https://github.com/bradmccormack/linux-amd-staging-drm-next-git/commit/97a1cf7ca577a4dc30adbd1adf5f86442e9ba559#diff-dfa7cdd9c34798e1af82f172b0822f08R90

It's definitely Linux 4.13 RC5 but the branch name is drm-next-4.15-dc and I updated the package before I understood properly. That's on me and my misunderstanding. It's clearly 4.13 https://cgit.freedesktop.org/~agd5f/linux/tree/Makefile?h=drm-next-4.15#n2

I'll fix that up (unless yurikoles gets to it first) and create a PR to fix this. Sorry for the confusion. I didn't intend my changes to be merged yet.

Strunkenbold commented on 2017-10-04 09:40

That doesnt look right, there is no kernel 4.15 yet. The code in the branch you selected will eventually be merged if Linus accepts it. Right now its based on 4.13.

edit: More precisely its based on Linux 4.13 RC5
https://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-next-4.15-dc&qt=grep&q=linux+4.1

yurikoles commented on 2017-09-25 18:29

Pull-requests are welcome: https://github.com/yurikoles/linux-amd-staging-drm-next-git

tscs37 commented on 2017-09-25 04:43

Is this package abandoned, considering the PKGBUILD has been broken for a while now.

All comments