Package Details: linux-firmware-iwlwifi-git 20191128.4bebf45-2

Git Clone URL: https://aur.archlinux.org/linux-firmware-iwlwifi-git.git (read-only, click to copy)
Package Base: linux-firmware-iwlwifi-git
Description: iwlwifi firmware files for linux
Upstream URL: git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git
Keywords: firmware git iwlwifi linux
Licenses: GPL2, custom, GPL3
Conflicts: amd-ucode, ar9170-fw, iwlwifi-1000-ucode, iwlwifi-3945-ucode, iwlwifi-4965-ucode, iwlwifi-5000-ucode, iwlwifi-5150-ucode, iwlwifi-6000-ucode, kernel26-firmware, linux-firmware, linux-firmware-git, linux-firmware-git-iwlwifi, rt2870usb-fw, rt2x00-rt61-fw, rt2x00-rt71w-fw
Provides: linux-firmware
Submitter: isiachi
Maintainer: elichai2
Last Packager: elichai2
Votes: 15
Popularity: 0.178062
First Submitted: 2016-09-20 21:20 (UTC)
Last Updated: 2020-05-17 12:53 (UTC)

Dependencies (1)

Required by (182)

Sources (1)

Latest Comments

Immortal commented on 2022-03-03 12:57 (UTC)

==> Starting pkgver()...
==> Updated version: linux-firmware-iwlwifi-git 20220110.8d8c6e9-1
==> Sources are ready.
==> Making package: linux-firmware-iwlwifi-git 20220110.8d8c6e9-1 (2022年03月03日 星期四 20时45分31秒)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Removing existing $pkgdir/ directory...
==> Starting check()...
E: iwlwifi-s0-a0-gf-a0.pnvm listed in WHENCE does not exist
E: iwlwifi-s0-a0-gf4-a0.pnvm listed in WHENCE does not exist
make: *** [Makefile:9:check] 错误 1
==> ERROR: A failure occurred in check().
    Aborting...
 -> error making: linux-firmware-iwlwifi-git

不行啊这,编译不了,请求大佬修复。

Ataraxy commented on 2022-02-15 14:49 (UTC)

Ditto.

==> Starting check()...
E: iwlwifi-s0-a0-gf-a0.pnvm listed in WHENCE does not exist
E: iwlwifi-s0-a0-gf4-a0.pnvm listed in WHENCE does not exist
make: *** [Makefile:9: check] Error 1
==> ERROR: A failure occurred in check().

Consider linux-firmware or linux-firmware-git instead.

Cysioland commented on 2022-02-07 16:01 (UTC)

Build fails for me

E: iwlwifi-s0-a0-gf-a0.pnvm listed in WHENCE does not exist
E: iwlwifi-s0-a0-gf4-a0.pnvm listed in WHENCE does not exist

Ataraxy commented on 2022-01-10 14:20 (UTC)

What is the advantage of this over:

https://archlinux.org/packages/core/any/linux-firmware/

raidgar98 commented on 2021-11-19 21:44 (UTC) (edited on 2021-11-19 21:44 (UTC) by raidgar98)

specs: System: 5.15.2-2-MANJARO CPU: AMD Ryzen 9 5950X network: Wi-Fi 6 AX200

got kernel panic

buuilding and instaling this: https://aur.archlinux.org/pkgbase/linux-firmware-git/

fixed problem (kernel panic)

bluetooth still not working

zayatura commented on 2021-09-14 16:10 (UTC)

The build fails for me:

==> Starting check()...
E: iwlwifi-so-a0-hr-a0-64.ucode listed in WHENCE does not exist
E: iwlwifi-so-a0-jf-a0-64.ucode listed in WHENCE does not exist
E: iwlwifi-so-a0-hr-b0-64.ucode not listed in WHENCE
E: iwlwifi-so-a0-jf-b0-64.ucode not listed in WHENCE
make: *** [Makefile:9: check] Error 1

imperssonator commented on 2021-09-09 15:51 (UTC)

this package fixed my intermittent 100ms ping issues I had with my intel ac 7260 on kernel 5.13.13-arch1-1.

Tried everything so I hope my comment can help people with the same problem.

francoism90 commented on 2021-05-21 22:21 (UTC)

Having the same question as @andrej, why does this conflict?

andrej commented on 2020-11-29 19:39 (UTC)

Out of curiosity, why does this package have a conflict with amd-ucode? It doesn't provide /boot/amd-ucode.img and the only conflicting file appears to be /usr/share/licenses/amd-ucode/LICENSE.amd-ucode.

elichai2 commented on 2020-05-17 12:26 (UTC)

Fixed :)

pozar87 commented on 2016-09-20 05:35 (UTC)

Hi, There is a little issue with .SRCINFO - please re-create it with mksrcinfo. Thanks for packaging :) Best Regards,

sebstar commented on 2016-08-13 23:36 (UTC)

Please bump to 20160725.26a5c2a-1

sebstar commented on 2016-05-15 10:09 (UTC)

==> Finished making: linux-firmware-git-iwlwifi 20160510.7c54290-1 (Sun May 15 12:07:51 CEST 2016) ==> Cleaning up... :: Installing linux-firmware-git-iwlwifi package(s)... :: linux-firmware-git-iwlwifi package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD.

allyourbase commented on 2016-05-09 14:22 (UTC)

I made the pkgver match the upstream commit date.

sebstar commented on 2016-05-09 12:14 (UTC)

Can confirm, still exists... Please fix, I update my system every day with pacaur and every day this package shows up. Thanks :)

NoSuck commented on 2016-05-01 16:48 (UTC)

... and I spoke too soon. Further testing has shown the problem still exists.

NoSuck commented on 2016-04-30 20:25 (UTC)

This package seems to solve the "iwlwifi: No association and the time event is over already..." system error upon resume from suspension that appeared sometime around linux-firmware 20160113.40e9ae8-1.

allyourbase commented on 2016-04-27 14:26 (UTC)

@Ferdi265, I do build it in a separate directory before I push. This was caused by me being unaware of the convention to match the PKGBUILD's pkgver to the upstream commit. I had simply put in the date of my commit in the PKGBUILD since it the package was flagged out of date.

yrlf commented on 2016-04-27 14:16 (UTC)

Actually: It's not broken. There IS no newer version than 20160331.91041a0-1. (Upstream is at this exact commit)

yrlf commented on 2016-04-27 14:10 (UTC)

Still broken; Still builds 20160331.91041a0-1. Next time, before pushing, run makepkg in there. If it gives you an older version, like 20160331.91041a0-1, fix it and then push.

allyourbase commented on 2016-04-26 13:21 (UTC)

Geeze, I still didn't push the file. I should have cloned the repo to validate. It's good now.

yrlf commented on 2016-04-26 05:57 (UTC)

Not yet. 1) It's still building Version 20160331.91041a0-1 instead of 20160425.75cc3ef-3 2) It fails installing with this error, actually getting the PKGBUILD and running mksrcinfo in that folder fixes it: :: linux-firmware-git-iwlwifi package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD.

allyourbase commented on 2016-04-25 21:04 (UTC)

I had pushed the wrong files. I think I straightened it out.

yrlf commented on 2016-04-25 20:40 (UTC)

@epinephrine: Can confirm. This is odd... Though what is also interesting is that the older package's .SRCINFO doesn't seem to have been generated by mksrcinfo (the "# generated by" line is missing).

sebstar commented on 2016-04-25 19:50 (UTC)

Something is odd here. makepkg reverts to pkgver=20160331.91041a0 as if this is the newest commit upstream. Anyone else experiencing this?

allyourbase commented on 2016-04-25 13:39 (UTC)

This is Intel's branch. Most, if not all of it aught to get merged with the mainline kernel somewhere down the line. This is just a way to get the Intel microcode a little sooner.

fackamato commented on 2016-04-25 03:44 (UTC)

What differs this from the regular linux-firmware-git ?

allyourbase commented on 2015-09-23 15:35 (UTC)

Added the linux-firmware conflict.

yurilebbie commented on 2015-09-23 04:51 (UTC)

You should make linux-firmware as a conflict of this package, as it won't install without removing it

allyourbase commented on 2015-08-12 19:02 (UTC)

Ahh, derp. I had copied the PKGBUILD from linux-firmware-git and had forgotten to change the source line. Fixed.

haagch commented on 2015-08-12 18:29 (UTC)

I mean, look at the source git repository. It's the same as the other package. I have looked for Emmanuel's repository but only found an old dead link...

allyourbase commented on 2015-08-12 14:19 (UTC)

You know, I never thought to check. I just did a quick md5sum/diff of everything and you're right. They're exactly the same.

haagch commented on 2015-08-12 12:36 (UTC)

There's no real difference to the linux-firmware-git package right now, right?