Package Details: linux-jcore-headers 6.1.8-2

Git Clone URL: https://aur.archlinux.org/linux-jcore.git (read-only, click to copy)
Package Base: linux-jcore
Description: Headers and scripts for building modules for the Kernel for Manjaro/EndeavourOS/Arch (ACS override patch include)
Upstream URL: https://www.kernel.org/
Keywords: acs kvm override passthrough pci qemu vfio vga
Licenses: GPL2
Replaces: linux-acs-manjaro, linux-acs-manjaro-headers
Submitter: Jeka
Maintainer: Jeka
Last Packager: Jeka
Votes: 1
Popularity: 0.158222
First Submitted: 2022-10-26 11:14 (UTC)
Last Updated: 2023-01-26 09:27 (UTC)

Required by (0)

Sources (26)

Pinned Comments

Jeka commented on 2022-10-26 15:09 (UTC) (edited on 2022-11-24 11:22 (UTC) by Jeka)

This kernel has patches from arch and manjaro, as well as an ACS patch.

How-To install: git clone https://aur.archlinux.org/linux-jcore.git && cd linux-jcore && makepkg -si

If you have an nvidia graphics card, don't forget to install dkms and nvidia-dkms

For better performance don't forget to replace in /etc/makepkg.conf (or in ~/.makepkg.conf) -march=x86-64 -mtune=generic with -march=native and MAKEFLAGS="-j2" with MAKEFLAGS="-j$(($(nproc)+1))"

Latest Comments

Dark_iaji commented on 2023-01-12 14:17 (UTC) (edited on 2023-01-12 14:17 (UTC) by Dark_iaji)

https://gitlab.manjaro.org/packages/core/linux60/-/issues/4

This patch has been accepted upstream, thanks for your continued work!🥰

Jeka commented on 2022-11-03 15:25 (UTC)

eclairevoyant, thanks for feedback. optdepends is added to PKGBUILD.

eclairevoyant commented on 2022-11-03 08:03 (UTC)

You don't need to "replace" /etc/makepkg.conf, you can just create a new file in your home dir (~/.makepkg.conf). Also, might be good to add nvidia-dkms to the optdepends to highlight it

Jeka commented on 2022-10-26 15:09 (UTC) (edited on 2022-11-24 11:22 (UTC) by Jeka)

This kernel has patches from arch and manjaro, as well as an ACS patch.

How-To install: git clone https://aur.archlinux.org/linux-jcore.git && cd linux-jcore && makepkg -si

If you have an nvidia graphics card, don't forget to install dkms and nvidia-dkms

For better performance don't forget to replace in /etc/makepkg.conf (or in ~/.makepkg.conf) -march=x86-64 -mtune=generic with -march=native and MAKEFLAGS="-j2" with MAKEFLAGS="-j$(($(nproc)+1))"