Package Details: linux-libre 4.7.4_gnu-1

Git Clone URL: https://aur.archlinux.org/linux-libre.git (read-only)
Package Base: linux-libre
Description: The Linux-libre kernel and modules
Upstream URL: http://linux-libre.fsfla.org/
Licenses: GPL2
Provides: linux=4.7.4
Replaces: linux
Submitter: fauno
Maintainer: Emulatorman
Last Packager: Emulatorman
Votes: 40
Popularity: 1.842386
First Submitted: 2011-08-09 21:26
Last Updated: 2016-09-21 14:25

Dependencies (12)

Required by (148)

Sources (29)

Latest Comments

xanc commented on 2016-09-18 11:34

Can anyone remove incompatibility from linux? It would allow have both: linux and linux-libre

SajeOne commented on 2016-02-15 13:45

Any ETA on a fix for the PGP sig issue?

Emulatorman commented on 2016-02-06 17:06

ok :)

JohnDVD commented on 2016-02-06 17:02

Sorry, I misstyped the key -_-

JohnDVD commented on 2016-02-06 16:55

Do you mean, I should leave out the pgp sig check?
I tried to find the key, but it seems to require a different keyserver. But I found no suitable one.

Emulatorman commented on 2016-02-06 16:48

JohnDVD, https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

JohnDVD commented on 2016-02-06 16:40

I have trouble with pgp signatures. It fails (unknown public key) for several files. How do I solve this?

Emulatorman commented on 2015-12-23 00:14

you're welcome onny! :)

onny commented on 2015-12-19 14:42

Okay cool, new version 4.3.3 works fine. Thanks for updating!

onny commented on 2015-12-14 14:16

Thank you for updating the package. Unfortunately I have problems compiling it:

CHK include/config/kernel.release
CHK include/generated/uapi/linux/version.h
CHK include/generated/utsrelease.h
CHK include/generated/bounds.h
CHK include/generated/timeconst.h
CHK include/generated/asm-offsets.h
CALL scripts/checksyscalls.sh
CHK include/generated/compile.h
CHK kernel/config_data.h
drivers/ipack/devices/.ipoctal.o.cmd:5: *** unterminated call to function 'wildcard': missing ')'. Stop.
scripts/Makefile.build:403: recipe for target 'drivers/ipack/devices' failed
make[2]: *** [drivers/ipack/devices] Error 2
scripts/Makefile.build:403: recipe for target 'drivers/ipack' failed
make[1]: *** [drivers/ipack] Error 2
Makefile:941: recipe for target 'drivers' failed
make: *** [drivers] Error 2
make 16.34s user 5.29s system 79% cpu 27.216 total

I'll investigate into this issue ...

Emulatorman commented on 2015-11-04 15:10

I built and maintain this package for Parabola distro [0] and i didn't have those problems. Also those patches comes officially from Linux-libre project [1], then it should be a problem either. I suggest remove src folder and try again.

[0]:https://www.parabola.nu/packages/libre/x86_64/linux-libre/
[1]:http://linux-libre.fsfla.org/pub/linux-libre/releases/4.2.5-gnu/

onny commented on 2015-11-04 14:32

Some patches won't apply or not working anymore:

The next patch would create the file tools/perf/arch/alpha/Build,
which already exists! Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored
The next patch would create the file tools/perf/arch/mips/Build,
which already exists! Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored
The next patch would create the file tools/perf/arch/parisc/Build,
which already exists! Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored

Emulatorman commented on 2015-10-09 00:26

linux-libre and linux aren't in conflict since 4.1.6_gnu-3 [0] and replaces array doesn't make effect for AUR packages if the package would conflict against Arch official packages, so it shouldn't be a problem. Otherwise, you can choose which kernel to boot from GRUB without problem.

[0]:https://aur.archlinux.org/cgit/aur.git/commit/?h=linux-libre&id=f52498ee7d059c786b33d948cfc24897147c89c0

bdantas commented on 2015-10-08 16:54

I would like to install linux-libre alongside linux. I'd be using linux-libre 99% of the time but on rare occasion I would need to boot with the non-free linux kernel. Can you please create the package without making it conflict with linux ("linux-libre and linux are in conflict"), so that I can choose which kernel to boot from GRUB? This would be analogous to having both linux and linux-lts installed together.

gim commented on 2015-05-24 08:11

Rearis, https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

Rearis commented on 2015-05-24 04:08

Still giving error:

==> ERRO: Uma ou mais assinaturas PGP não puderam ser verificadas!
==> ERRO: Makepkg não conseguiu compilar linux-libre.

Rearis commented on 2015-05-23 07:47

Can you update please? I can't install :(

klenamenis commented on 2015-01-09 00:48

Why can this kernel not be installed besides the default "linux" package as any other (custom) kernel?

Emulatorman commented on 2014-11-27 21:29

done :)

gim commented on 2014-11-27 11:56

You may also want to add signatures to the "source" :)

http://linux-libre.fsfla.org/pub/linux-libre/releases/3.17-gnu/linux-libre-3.17-gnu.tar.xz.sign
http://linux-libre.fsfla.org/pub/linux-libre/releases/3.17.4-gnu/patch-3.17-gnu-3.17.4-gnu.xz.sign

fauno commented on 2012-11-08 18:16

PKGBUILD is getting too complex for AUR :P

Det commented on 2012-08-15 09:47

404 with the 'linux-patches-3.5.6-gnu_0loongsonlibre_mipsel.tar.bz2'.

falconindy commented on 2011-10-08 17:31

Merging into linux-libre.

fauno commented on 2011-08-09 21:27

Binary packages on Parabola's [libre] repo: http://repo.parabolagnulinux.org/libre

fauno commented on 2011-08-09 21:25

Will be dropped in favor of 'linux-libre' :)

fauno commented on 2011-07-09 23:12

2.6.39.3 is not out yet, but I'll skip 2.6.39.2

fauno commented on 2011-06-23 05:40

Binary packages are available at http://repo.parabolagnulinux.org/libre

fauno commented on 2011-04-23 22:14

working on the update.

smoge: it only conflicts with kernel26 from [core], just because this one is a libre replacement for it (not a patched kernel).

smoge commented on 2011-04-16 15:14

Why it conflicts with all other kernels in the system? This shouldn't be that way I think.

fauno commented on 2011-03-31 13:43

Binary packages are available at http://repo.parabolagnulinux.org/libre-testing

fauno commented on 2011-03-12 02:17

No more deblobing ;)

fauno commented on 2011-01-07 15:01

updated. this pkgbuilds downloads the unfree sources and deblobs them using linux-libre scripts, after applying arch's patches. in the 2.6.37 version [1] the patches are applied over linux-libre sources. i don't upload it yet because is in testing stage.

IMPORTANT: this package replaces the official kernel26. but it's working ok :)

[1] http://repo.parabolagnulinux.org/pkgbuilds/core/kernel26-libre-2.6.37-1.src.tar.gz

ISF commented on 2010-09-26 16:49

Hi, can you update this package please? libre 2.6.35.5 works fine on arch (compiled by hand).