Package Details: linux-lts414 4.14.326-1

Git Clone URL: (read-only, click to copy)
Package Base: linux-lts414
Description: The Linux-lts414 kernel and modules
Upstream URL:
Licenses: GPL2
Submitter: severach
Maintainer: severach
Last Packager: severach
Votes: 9
Popularity: 0.20
First Submitted: 2019-01-01 20:55 (UTC)
Last Updated: 2023-09-24 17:01 (UTC)

Latest Comments

1 2 3 4 Next › Last »

City-busz commented on 2023-01-19 03:04 (UTC)

I would suggest the following changes:

  1. Apply this patch to avoid this error during installation with kmod>=30: ==> ERROR: file not found: `/lib/modules/4.14.303-1-lts414/modules.builtin.modinfo'

  2. Install the kernel image into /usr/lib/modules/4.14.303-1-lts414/vmlinuz instead of /boot and add the file /usr/lib/modules/4.14.303-1-lts414/pkgbase in order to make the package compatible with the libalpm hooks shipped with recent mkinitcpio versions. After that the custom mkinitcpio preset and libalpm hooks can be removed from this package, and the 'mkinitcpio' dependency can be replaced with 'initramfs' as the package will be compatible with other initramfs generators as well.

ReDemoNBR commented on 2022-04-19 21:22 (UTC)

Forgot to update the checksums for the patch-4.14.275.xz source. Here they are for your convenience:

  • md5sum: d3d0e1a2a504d9f411ed0688240f1ade
  • sha256sum: 50da7207d314b8668259433738accbcd85046d7fa452302b229298e4ad45a4d5

jonathon commented on 2022-01-21 20:54 (UTC)

I've packaged up linux-firmware-uncompressed for kernels affected by module compression in linux-firmware 20220119.0c6a7b3-2.

severach commented on 2021-02-09 22:54 (UTC)

Downgrade to binutils 2.35.1-1 to build.

eschwartz commented on 2021-01-03 01:11 (UTC)

Unless you provide the same uname -r and /lib/modules/${_kernver}/ directory (protip: you don't, this is based on _kernelname=${pkgbase#linux}) you do not provide the right interface to support modules compiled for core/linux... NOT EVEN modules compiled for core/linux 4.14.x from way back in 2018.

Now, you were warned by both me and Scimmia, which is twice the warnings you had a right to receive, but I am a gracious person... the next step is I'm going to delete this package if you do anything other than remove the provides. I am speaking with my TU hat on -- I will not listen to further arguments, and you will not get another warning.

severach commented on 2021-01-02 07:03 (UTC) (edited on 2021-01-02 09:49 (UTC) by severach)

It's not broken so it won't be fixed. Arch is a source distro so you are wrong, provides is right. Nvidia needs a depends=(linux-headers=version). All other modules work correctly with provides. Please submit a bug report to add provides to linux-lts. What really need is two provides, provides=4.14 and provides=4.14.x for kernel version particular modules. We could also make up fake package names so modules could depend on them or the original names as desired. Same as Java.

Scimmia commented on 2021-01-02 05:12 (UTC)

2 updates and the provides still isn't fixed

Scimmia commented on 2020-12-11 00:39 (UTC)

nvidia? broadcom-wl? Every single module in the repos?

severach commented on 2020-12-11 00:22 (UTC)

What package has such a module? Don't reference any DKMS packages because my settings are there to support those packages, not packages with kernel modules inexplicably compiled for the latest kernel but with no source available.