Package Details: linux-rt-docs 4.16.18_rt12-1

Git Clone URL: https://aur.archlinux.org/linux-rt.git (read-only)
Package Base: linux-rt
Description: Kernel hackers manual - HTML documentation that comes with the Linux-rt kernel
Upstream URL: https://www.kernel.org/
Licenses: GPL2
Submitter: schivmeister
Maintainer: jhernberg
Last Packager: jhernberg
Votes: 149
Popularity: 0.461109
First Submitted: 2011-08-09 20:03
Last Updated: 2018-08-04 12:33

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Ralf_Mardorf commented on 2018-08-30 07:23

CyrIng, somewhere the comments of the last four month contain a reply regarding this "issue". I read comments until I found this reply and then I replied to your comment. Writing the reply to you, needed more time, than to search the other reply.

CyrIng commented on 2018-08-30 01:07

makepkg stops with: ==> Verifying source file signatures with gpg...
linux-4.16.tar ... FAILED (unknown public key 79BE3E4300411886)
patch-4.16.18 ... FAILED (unknown public key 38DBBDC86092693E)
patch-4.16.18-rt12.patch ... FAILED (unknown public key 4FE5E3262872E4CC)
==> ERROR: One or more PGP signatures could not be verified!

blackhole commented on 2018-08-29 22:06

Yes, there is not more the module and efi=runtime is working. Thanks

jhernberg commented on 2018-08-29 21:56

@blackhole: I don't think there is such a module. The /sys/firmware/efi/efivars/ issue seems to be a bug in the rt patch, but it gets populated if you add the efi=runtime boot flag.

kureta commented on 2018-08-25 20:02

I have updated my gcc to 8.2.0, then reinstalled linux-rt with "clean-build" option using yay.It should have been built using gcc 8.2.0 but I've got this error anyway when I tried to dkms install nvidia/396.54 -k 4.16.18-rt12-1-rt. So I've set IGNORE_CC_MISMATCH=1 to install it anyway.

jhernberg commented on 2018-08-25 11:02

No don't change anything in the kernel config. The error msg says that your kernel is built with 8.1.1, did you reinstall it before building linux-rt again?

If you use devtools, there ought to be no problem at all, no matter what you have installed on your local system, that's exactly the reason to use devtools..

kureta commented on 2018-08-25 10:56

@jhernberg: build just finished and it gave the same error while automatically installing nvidia-dkms.

Compiler version check failed:

The major and minor number of the compiler used to compile the kernel:
gcc version 8.1.1 20180531 (GCC)
does not match the compiler used here:
cc (GCC) 8.2.0

I have checked my gcc version. it is 8.2.0. Should I also clean build nvidia-dkms?

kureta commented on 2018-08-25 10:46

@jhernberg: Yes, I just realized that I should rebuild the kernel instead of downgrading gcc. You are right it should rebuild dkms modules during installation. I am currently rebuilding and it takes a long time. I am using yay. I actually interrupted the building process half way through to edit the PKGBUILD file and add -j8 argument and restarted the build. By the way, should I change anything in menuconfig? I saw those lines were commented out.

jhernberg commented on 2018-08-25 10:06

@kureta: No need for that, just rebuild the kernel, and when you install it again then nvidia-dkms will be run again. If for some reason that isn't easy with whatever aur helper you might be using, do this:

Get the buildscript with "cower -d linux-rt", then change to the linux-rt dir and run, "makepkg -cfi". Even better would be to install devtools, and then run "extra-x86_64-build" which will install and update a chroot with all dependencies installed and then run makepkg. When done install manually with "pacman -U".

To use all cpus for compiling, edit /etc/makepkg.conf and make sure that you have something like MAKEFLAGS="-j9".

@blackhole: I'll look into it.

kureta commented on 2018-08-25 09:06

For all those nvidia-dkms folks out there. I had similar problems and found the reason to be gcc updates in-between linux-rt and nvidia-dkms updates. My specific problem was that linux-rt was compiled using gcc 8.1.1 and later gcc was updated to 8.2.0. Now if nvidia-dkms is updated it gives an error stating there is a version mismatch between the compiler used to compile the rt kernel and the current compiler. It is easy to miss the error during a system update.

What I did was to downgrade gcc and run sudo dkms autoinstall. You can find the specific gcc versions here: /var/lib/dkms/nvidia/<YOUR NVIDIA_DKMS VERSION>/build/make.log.

Currently I am trying to reinstall linux-rt with clean build and use the latest gcc without downgrading. It seems like a better solution but I didn't want to do that because compiling the kernel takes a very long time. I guess it does not use all cores.