Package Details: linux-steam-integration 0.7.3-4

Git Clone URL: https://aur.archlinux.org/linux-steam-integration.git (read-only, click to copy)
Package Base: linux-steam-integration
Description: Helper for enabling better Steam integration on Linux
Upstream URL: https://github.com/getsolus/linux-steam-integration
Keywords: linux-steam-integration solus steam
Licenses: LGPL2.1
Provides: liblsi-intercept.so-32, liblsi-intercept.so-64, liblsi-redirect.so-32, liblsi-redirect.so-64
Submitter: z3ntu
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 28
Popularity: 0.029341
First Submitted: 2016-07-19 12:53 (UTC)
Last Updated: 2022-10-20 18:21 (UTC)

Pinned Comments

yochananmarqos commented on 2021-11-29 17:58 (UTC)

With the most recent Steam update, you'll need to disable Use the intercept library.

Latest Comments

1 2 3 Next › Last »

yochananmarqos commented on 2022-04-08 17:01 (UTC)

@JacekJagosz: Thanks, hadn't noticed they were maintaining it again.

JacekJagosz commented on 2022-04-08 12:33 (UTC)

Maybe you could consider switching to https://github.com/getsolus/linux-steam-integration ? It is actively maintained, and used on Solus by default, so when something breaks on Solus with Steam or depencency update, it gets updated too. Meanwhile Ikey left Clear Linux long ago, and nobody is maintaining it anymore there.

binarynoise commented on 2022-03-25 08:00 (UTC)

Build fails because signature can't be verified

yochananmarqos commented on 2021-11-29 17:58 (UTC)

With the most recent Steam update, you'll need to disable Use the intercept library.

sampa82 commented on 2020-12-09 17:33 (UTC)

Pretty sure this project is dead, do you guys find that it still works?

snostorm commented on 2020-03-25 22:25 (UTC)

can we get the diff kode54 has below integrated as patch until it is fixed in the master branch. I tested it and it works fine.

thaewrapt commented on 2020-02-02 19:49 (UTC)

@kode54 actually, I've found a fork with this particular change already: https://github.com/BlackholeEscaper/linux-steam-integration

Dunno, why it hasn't got a pull-request into the mainline for that long, or if it's even working (haven't checked yet).

kode54 commented on 2020-01-28 09:18 (UTC)

Easy enough to fix upstream, or fix in this repository, in case it's not applicable to upstream:

diff -urN linux-steam-integration-0.7.3-orig/src/intercept/main.c linux-steam-integration-0.7.3/src/intercept/main.c
--- linux-steam-integration-0.7.3-orig/src/intercept/main.c 2020-01-28 01:17:13.983437325 -0800
+++ linux-steam-integration-0.7.3/src/intercept/main.c  2020-01-28 01:17:32.551437453 -0800
@@ -323,7 +323,7 @@
         "libcurl-gnutls.so.4",
         "libcurl.so.4",

-        "libbz2.so.1.0.6",
+        "libbz2.so.1.0.8",

         "libudev.so.1",
 };

Best also check this in case there are any other intercepts that point at obsolete SONAMEs.

ozmartian commented on 2019-10-10 02:24 (UTC) (edited on 2019-10-10 02:24 (UTC) by ozmartian)

this is a hack to get it working until things are fixed upstream. just create symbolic links to the latest bz2 lib in BOTH x64 and x32 lib folders. make a note of this so you can clean it up when this is properly fixed.

$ sudo ln -s /usr/lib/libbz2.so.1.0.8 /usr/lib/libbz2.so.1.0.6

$ sudo ln -s /usr/lib32/libbz2.so.1.0.8 /usr/lib32/libbz2.so.1.0.6