Package Details: linux-versioned-bin 5.19.10.arch1-1

Git Clone URL: https://aur.archlinux.org/linux-versioned-bin.git (read-only, click to copy)
Package Base: linux-versioned-bin
Description: Metapackage depending on linux5.19.10.arch1-1-bin
Upstream URL: https://github.com/archlinux/linux/commits/v5.19.10-arch1
Licenses: GPL2
Submitter: chrisjbillington
Maintainer: chrisjbillington
Last Packager: chrisjbillington
Votes: 5
Popularity: 0.000046
First Submitted: 2020-02-19 21:45 (UTC)
Last Updated: 2022-09-24 00:00 (UTC)

Pinned Comments

chrisjbillington commented on 2020-02-28 17:48 (UTC) (edited on 2022-04-10 02:40 (UTC) by chrisjbillington)

These packages allow you to have multiple versions of the Arch kernel installed simultaneously. The intended use is to install the linux-versioned-bin (and linux-versioned-headers-bin if you use out-of-tree drivers) metapackage, using an AUR helper or otherwise in a way that automatically processes dependencies. This metapackage depends on the latest versioned kernel package, but older kernel packages will remain on your system as orphaned packages to be removed later. You can find and remove them with the remove-orphaned-kernels script, which will uninstall orphaned kernel packages except those corresponding to the kernel that is currently running. If you use GRUB, you will also need to ensure its config is updated after kernels are added or removed. Installing the grub-hook package will ensure this is done automatically.

To switch from the regular Arch kernel package to these versioned packages, you can do the following (using the AUR helper yay for example):

# Remove linux, linux-headers if installed, and any out-of-tree drivers for the regular kernel:
$ pacman -Rs linux [linux-headers] [nvidia] [...]
# Install dkms versions of any out-of-tree drivers you need:
$ pacman -S [nvidia-dkms] [...]
# If using GRUB, install grub-hook before installing kernels:
$ yay -S grub-hook
# Install the kernel metapackage, and headers metapackage if you use out-of-tree drivers:
$ yay -S linux-versioned-bin [linux-versioned-headers-bin]

This is also discussed here.

See also:

Latest Comments

1 2 Next › Last »

G3ro commented on 2022-01-13 22:34 (UTC)

@chrisjbillington Thx for the fast solution.

chrisjbillington commented on 2022-01-13 21:08 (UTC)

Thanks for pointing this out @G3ro, this is now fixed.

It was a problem when the kernel version ends in .0. In this case filepaths contain a .0, e.g. /usr/lib/modules/5.16.0-arch1-1 but the pkgver does not, e.g. 5.16.arch1. The code that updates the PKGBUILD assumed that these would be the same, but they're not. So I've updated it to append the .0 where necessary.

G3ro commented on 2022-01-13 15:57 (UTC) (edited on 2022-01-13 16:00 (UTC) by G3ro)

5.16 is failing with the following message (translated by me):

sed: /var/tmp/pamac-build-toby/linux-versioned-bin/pkg/linux5.16.arch1-1-bin/usr/lib/modules/5.16-arch1-1/pkgbase cannot be read: file or folder not found ==> Error: An error occured in package_linux5.16.arch1-1-bin().

chrisjbillington commented on 2021-11-14 21:07 (UTC)

@Madic I've reverted the change that added provides=(linux). As another user quickly pointed out to me, this prevents having multiple kernel packages installed simultaneously, and I am guessing I left it out intentionally when I first made this package for this reason. As mentioned, the solution to the problem you were facing is to use dkms versions of the modules you need.

chrisjbillington commented on 2021-11-14 12:32 (UTC)

@Madic, actually I've realised that the two packages you have that require linux are kernel modules.

They will only work with the latest kernel package, and not with older versioned kernels. They will also have older versions uninstalled upon upgrade, both of these things defeating the purpose of versioned kernel installs.

As discussed in the pinned comment, you should install tp_smapi-dkms and r8168-dkms instead, which will work with all kernel versions (be sure to install linux-versioned-headers-bin as well).

Madic commented on 2021-11-14 12:04 (UTC)

@chrisjbillington this has worked, thank you!

chrisjbillington commented on 2021-11-14 11:59 (UTC)

Thanks for the suggestion @Madic, done.

No pkgrel bump since this package tracks the upstream versions exactly, so you'll need to makepkg -f or whatnot to make sure it actually rebuilds.

Madic commented on 2021-11-14 11:43 (UTC) (edited on 2021-11-14 11:44 (UTC) by Madic)

Can you add "provides: linux" to the package? It breaks two packages for me:

:: linux5.15.2.arch1-1-bin and linux are in conflict. Remove linux? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux breaks dependency 'linux' required by r8168
:: removing linux breaks dependency 'linux' required by tp_smapi
 -> exit status 1

chrisjbillington commented on 2021-04-21 23:08 (UTC)

@patlefort yes, not much trouble, here you go:

https://aur.archlinux.org/pkgbase/linux-zen-versioned-bin

Please test :)