Package Details: linux-xanmod-anbox-headers 5.18.16-1

Git Clone URL: https://aur.archlinux.org/linux-xanmod-anbox.git (read-only, click to copy)
Package Base: linux-xanmod-anbox
Description: The Linux kernel and modules with Xanmod patches and ashmem and binder enabled
Upstream URL: http://www.xanmod.org/
Licenses: GPL2
Submitter: mikewashere
Maintainer: mikewashere
Last Packager: mikewashere
Votes: 7
Popularity: 0.003753
First Submitted: 2020-08-16 15:32 (UTC)
Last Updated: 2022-08-05 00:03 (UTC)

Pinned Comments

mikewashere commented on 2020-08-16 17:06 (UTC)

This PKGBUILD is automatically generated from https://aur.archlinux.org/packages/linux-xanmod/ every day at 00:00 UTC. Please read the comments in that repo, before commenting here. Also, see the pinned post there for customization options.

Latest Comments

n43 commented on 2022-07-01 12:58 (UTC) (edited on 2022-07-01 13:00 (UTC) by n43)

[na3@blackarch]-[~]
yay -Sy --noconfirm linux-xanmod-anbox linux-xanmod-anbox-headers

[na3@blackarch]-[~]
uname -a
Linux blackarch 5.18.8-xanmod1-1 #1 SMP Fri, 01 Jul 2022 07:28:21 +0000 x86_64 GNU/Linux

[na3@blackarch]-[~]
modprobe binder_linux devices=binder,hwbinder,vndbinder,anbox-binder,anbox-hwbinder,anbox-vndbinder

[na3@blackarch]-[~]
modprobe ashmem_linux                                                               modprobe: FATAL: Module ashmem_linux not found in directory /lib/modules/5.18.8-xanmod1-1


someone can help me to get anbox working please?

k0r0ng commented on 2022-01-12 14:48 (UTC)

Why this package exist? Isn't anbox module included in linux-xanmod?

kode54 commented on 2021-09-05 02:24 (UTC)

Your automatic generator made a mess of the latest PKGBUILD, it inserted the Anbox rules right in the middle of an if/fi block specific to building with clang.

emceebois commented on 2021-07-21 15:01 (UTC)

Didn't this used to be on 5.13.x? Now when I try to run yay -Syyu it keeps skipping this since it thinks the "new" 5.12.x release is older than what I currently have. Are there problems with the 5.13.x version that I simply haven't run into yet? Is there a timetable for rebasing on 5.13.x going forward?

gyurman commented on 2021-07-11 10:30 (UTC)

júl 11 09:54:18 gigarch kernel: Error: Driver 'pcspkr' is already registered, aborting... júl 11 09:54:13 gigarch kernel: usb usb7-port4: unable to enumerate USB device júl 11 09:54:13 gigarch kernel: usb 7-4: device not accepting address 9, error -32 júl 11 09:54:13 gigarch kernel: usb 7-4: device not accepting address 8, error -32 júl 11 09:54:13 gigarch kernel: usb 7-4: device descriptor read/64, error -32 júl 11 09:54:13 gigarch kernel: usb usb7-port1: unable to enumerate USB device júl 11 09:54:13 gigarch kernel: usb 7-1: device not accepting address 5, error -32 júl 11 09:54:13 gigarch kernel: usb usb5-port1: unable to enumerate USB device júl 11 09:54:13 gigarch kernel: usb 7-1: device descriptor read/64, error -32 júl 11 09:54:13 gigarch kernel: usb 5-1: device descriptor read/64, error -32 júl 11 09:54:13 gigarch kernel: usb 7-1: device descriptor read/64, error -32

simona commented on 2021-02-25 12:31 (UTC)

when i install this package it seems i should uninstall linux-xanmod first. can I install the 2 kernels together? or it just doesn't make sense and can I give up linux-xanmod base? why so much "distrust" towards ashmem and binder? are they heavy and slow down the kernel?

tsbarnes commented on 2021-02-22 18:19 (UTC)

The 5.11.0 build seems to be missing the anbox modules

Scimmia commented on 2020-12-10 16:43 (UTC)

Please see the warning here: https://wiki.archlinux.org/index.php/Kernel/Arch_Build_System#Modifying_the_PKGBUILD

mikewashere commented on 2020-08-16 17:06 (UTC)

This PKGBUILD is automatically generated from https://aur.archlinux.org/packages/linux-xanmod/ every day at 00:00 UTC. Please read the comments in that repo, before commenting here. Also, see the pinned post there for customization options.