Package Details: linuxqq-appimage-latest 0.1.1-2

Git Clone URL: https://aur.archlinux.org/linuxqq-appimage-latest.git (read-only, click to copy)
Package Base: linuxqq-appimage-latest
Description: New Linux QQ based on Electron
Upstream URL: https://im.qq.com/linuxqq/
Keywords: appimage electron latest linuxqq qq tencent
Licenses: custom
Conflicts: linuxqq, linuxqq-nt-bwrap
Provides: linuxqq, qq
Submitter: fengch
Maintainer: fengch
Last Packager: fengch
Votes: 1
Popularity: 0.053365
First Submitted: 2023-10-08 10:53 (UTC)
Last Updated: 2024-01-31 05:22 (UTC)

Pinned Comments

fengch commented on 2023-10-08 10:54 (UTC)

这个包就是安装一下linuxqq 然后就让qq自行管理qq更新了

Latest Comments

Paeonia commented on 2023-10-23 04:33 (UTC)

@fengch 已经用上了!谢谢大大~

fengch commented on 2023-10-23 01:28 (UTC)

@Paeonia 问题解决了~

fengch commented on 2023-10-22 04:29 (UTC)

不对,好像是有点问题,在安装目录下 手动 执行一下 npm install 之就能安装了,我看看是什么原因导致的

fengch commented on 2023-10-22 04:16 (UTC)

补全了缺失的 npm 依赖, 你这段报错是找不到依赖的 sync-request 模块

尝试给 npm 配置一下镜像或者科学上网,应该是从库没拉到

Paeonia commented on 2023-10-21 09:16 (UTC)

安装nodejs后不包含npm,而PKGBUILD中需要,因此我安装了一下,而安装npm之后安装中依然报错。但我不会解决。我决定暂时用隔壁 linuxqq-appimage

报错信息如下

==> 正在验证 source 文件,使用sha256sums...
    get_latest ... 通过    package.json ... 通过    package-lock.json ... 通过==> 正在删除现存的 $srcdir/ 目录...
==> 正在释放源码...
==> 正在开始 prepare()...
(node:34675) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 close listeners added to [TLSSocket]. Use emitter.setMaxListeners() to increase limit
# 中间省略好多行node:34675的报错
(node:34675) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 close listeners added to [TLSSocket]. Use emitter.setMaxListeners() to increase limit

added 42 packages, and audited 43 packages in 15s

7 packages are looking for funding
  run `npm fund` for details

found 0 vulnerabilities
node:internal/modules/cjs/loader:1051
  throw err;
  ^

Error: Cannot find module 'sync-request'
Require stack:
- /home/user/.cache/paru/clone/linuxqq-appimage-latest/get_latest
    at Module._resolveFilename (node:internal/modules/cjs/loader:1048:15)
    at Module._load (node:internal/modules/cjs/loader:901:27)
    at Module.require (node:internal/modules/cjs/loader:1115:19)
    at require (node:internal/modules/helpers:130:18)
    at Object.<anonymous> (/home/user/.cache/paru/clone/linuxqq-appimage-latest/get_latest:5:21)
    at Module._compile (node:internal/modules/cjs/loader:1241:14)
    at Module._extensions..js (node:internal/modules/cjs/loader:1295:10)
    at Module.load (node:internal/modules/cjs/loader:1091:32)
    at Module._load (node:internal/modules/cjs/loader:938:12)
    at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:83:12) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [ '/home/user/.cache/paru/clone/linuxqq-appimage-latest/get_latest' ]
}

fengch commented on 2023-10-08 10:54 (UTC)

这个包就是安装一下linuxqq 然后就让qq自行管理qq更新了