Package Details: linvst3-bin 4.5.2-1

Git Clone URL: https://aur.archlinux.org/linvst3-bin.git (read-only, click to copy)
Package Base: linvst3-bin
Description: Linux Windows vst3 wrapper/bridge
Upstream URL: https://github.com/osxmidi/LinVst3
Keywords: audio bitwig vst vst2 vst3
Licenses: GPL
Conflicts: linvst3
Submitter: madskjeldgaard
Maintainer: kingwill101
Last Packager: kingwill101
Votes: 3
Popularity: 0.000034
First Submitted: 2020-09-26 19:59 (UTC)
Last Updated: 2021-09-04 23:16 (UTC)

Pinned Comments

kingwill101 commented on 2021-08-12 15:36 (UTC)

i have gone ahead and made my update scripts public in case i'm no longer able to maintain this package

https://github.com/glenfordwilliams/AUR-packages

Latest Comments

LINCKODE commented on 2022-03-08 17:07 (UTC)

Updated PKGBUILD:

# Maintainer: Mads Kjeldgaard <mail@madskjeldgaard.dk>
pkgname=linvst3-bin
pkgver=4.7.1
pkgrel=1
pkgdesc="Linux Windows vst3 wrapper/bridge"
arch=('x86_64')
url="https://github.com/osxmidi/LinVst3"
license=('GPL')
groups=('pro-audio')
depends=('wine' 'gtk3')
conflicts=('linvst3')
optdepends=('jack')
source=("https://github.com/osxmidi/LinVst3/releases/download/4.7.1/LinVst3-4.7.1.zip")
md5sums=('167c40d660008f34b056cebba90707e2')

package() {

    # Shared library
    install -Dm755 "$srcdir/LinVst3-$pkgver/linvst3.so" "$pkgdir/usr/share/LinVst/linvst3.so"

    # Embedded
    install -Dm755 "$srcdir/LinVst3-$pkgver/lin-vst3-servertrack.exe" "$pkgdir/usr/bin/lin-vst3-servertrack.exe"
    install -Dm755 "$srcdir/LinVst3-$pkgver/lin-vst3-servertrack.exe.so" "$pkgdir/usr/bin/lin-vst3-servertrack.exe.so"

    # Converter
    install -Dm755 "$srcdir/LinVst3-$pkgver/linvst3convert" "$pkgdir/usr/bin/linvst3convert"

    #test
    install -Dm755 "$srcdir/LinVst3-$pkgver/TestVst3/testvst3.exe" "$pkgdir/usr/bin/testvst3.exe"
    install -Dm755 "$srcdir/LinVst3-$pkgver/TestVst3/testvst3.exe.so" "$pkgdir/usr/bin/testvst3.exe.so"


}

kingwill101 commented on 2021-09-04 23:19 (UTC) (edited on 2021-09-04 23:20 (UTC) by kingwill101)

md5sum updated

Elmario commented on 2021-08-22 19:57 (UTC)

Hello!

How can I solve this problem, please?

"Vorbereitung... Klone linvst3-bin Build-Dateien... Überprüfe linvst3-bin Abhängigkeiten... Synchronisiere Paketdatenbanken... Warnung: libvirt: Ignoriere Paket-Aktualisierung (1:7.5.0-1 => 1:7.6.0-1) Warnung: manjaro-hello: Lokale Version (0.6.7-2) ist neuer als extra (0.6.6-8) Abhängigkeiten werden aufgelöst... Interne Konflikte werden überprüft...

Erstelle linvst3-bin... ==> Erstelle Paket: linvst3-bin 4.5.2-1 (So 22 Aug 2021 21:55:46 CEST) ==> Prüfe Laufzeit-Abhängigkeiten... ==> Prüfe Buildtime-Abhängigkeiten... ==> Empfange Quellen... -> LinVst3-4.5.2-Manjaro.zip gefunden ==> Überprüfe source Dateien mit md5sums... LinVst3-4.5.2-Manjaro.zip ... FEHLGESCHLAGEN ==> FEHLER: Eine oder mehrere Dateien überstanden nicht die Gültigkeits-Prüfung! Fehler beim Erstellen von linvst3-bin"

It has been bothering me for many weeks now, on every update.

kingwill101 commented on 2021-08-12 15:36 (UTC)

i have gone ahead and made my update scripts public in case i'm no longer able to maintain this package

https://github.com/glenfordwilliams/AUR-packages

letgo100 commented on 2021-04-09 05:33 (UTC)

Unfortunately getting md5sum check errors myself now :(

madskjeldgaard commented on 2021-01-09 15:35 (UTC)

hey @Night. Sorry about that. Should be fixed now

Night commented on 2021-01-05 20:47 (UTC)

Hey LinVst3-2.15-Debian-Stretch.zip fails md5sum check for me