Package Details: liquidsoap 1.4.0-2

Git Clone URL: https://aur.archlinux.org/liquidsoap.git (read-only, click to copy)
Package Base: liquidsoap
Description: A swiss-army knife for multimedia streaming, notably used for netradios and webtvs
Upstream URL: https://www.liquidsoap.info
Licenses: GPL
Conflicts: liquidsoap-full, liquidsoap-git
Submitter: mefistofeles
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 11
Popularity: 0.56
First Submitted: 2009-02-14 21:32
Last Updated: 2019-12-15 14:15

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

danny8376 commented on 2016-08-02 14:34

Command "patch -Np1 -i "${srcdir}/ffmpeg_fixes.patch"" in prepare() should be removed.

leonardder commented on 2016-07-26 17:46

I'm sorry I haven't jumped on this earlier. I've removed the patch, please let me know whether it works now. If not, change ffmpeg dependency to ffmpeg2.8 and try again.

5chdn commented on 2016-07-22 15:05

Does not build currently:

==> Extracting sources...
-> Extracting liquidsoap-1.2.1-full.tar.gz with bsdtar
==> Starting prepare()...
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- liquidsoap-1.2.0-full/ocaml-ffmpeg-0.1.1/src/avutil_stubs.c 2015-08-03 17:47:57.000000000 +0200
|+++ avutil_stubs.c 2016-03-26 17:11:26.000000000 +0100
--------------------------
File to patch:

It asks which file to patch. What to do?

mutantmonkey commented on 2016-07-05 06:54

I'm not sure if ffmpeg_fixes.patch is still necessary or not, but since it refers to old paths it should be updated or removed. The build was breaking for me in the prepare() function.

After fixing that, I still ran into another issue that I was able to figure out, but I'll leave it here in case anyone else runs into the same issue:

OCAMLOPT -o liquidsoap
File "_none_", line 1:
Error: Files /usr/lib/ocaml/yojson/yojson.cmx
and /usr/lib/ocaml/easy-format/easy_format.cmx
make inconsistent assumptions over interface Easy_format
make[3]: *** [../Makefile.rules:110: liquidsoap] Error 2
make[3]: Leaving directory '/home/mutantmonkey/builds/liquidsoap/src/liquidsoap-1.2.1-full/liquidsoap-1.2.1/src'
make[2]: *** [../Makefile.rules:67: all-auto-ocaml-prog] Error 2
make[2]: Leaving directory '/home/mutantmonkey/builds/liquidsoap/src/liquidsoap-1.2.1-full/liquidsoap-1.2.1/src'
make[1]: *** [Makefile.rules:27: all-subdirs] Error 2
make[1]: Leaving directory '/home/mutantmonkey/builds/liquidsoap/src/liquidsoap-1.2.1-full/liquidsoap-1.2.1'
make: *** [Makefile:11: all] Error 1
==> ERROR: A failure occurred in build().
Aborting...

It turned out that I had to rebuild ocaml-biniou, ocaml-easy-format, and ocaml-yojson (in that order), and I was able to build Liquidsoap.

Thanks for the package!

melvinvermeeren commented on 2016-04-29 18:35

After updating soundtouch from 1.9.0-3 to 1.9.2-1 and recompiling liquidsoap segfaults on start, even with something like --help.

Can't find anything about it online, running it with gdb gives:
Program received signal SIGSEGV, Segmentation fault.
0x00000000007d1314 in caml_copy_string ()

Anyone else experiencing the problem?

leonardder commented on 2016-03-26 16:26

I've just created a patch which updates ocaml-ffmpeg to the newest version from source. Could anyone try this with the ffmpeg version from the arch repo?

leonardder commented on 2016-03-23 08:56

That probably means you can build liquidsoap-git correctly.

Ryex commented on 2016-03-23 08:38

it seems a fix was applied upstream to build with 3.0 in the ocaml-ffmpeg repo but that commit has not been linked into the liquidsoap-full repo. I'll be on the lookout for when it is and let you know

Ryex commented on 2016-03-23 07:59

unfortunately not as the correct 2.8 header files are included under /usr/include/ffmpeg2.8/ not /usr/include and it's entirely possible to have ffmpeg2.8 and ffmpeg installed at the same time. some sort of patch or configuration change will be needed to account for that.

sadly just adding

CPPFLAGS="-I/usr/include/ffmpeg2.8" LDFLAGS="-L/usr/include/ffmpeg2.8"

to the end of the configure line doesn't work. it will compile but when it comes time to link this happens:

OCAMLOPT -o liquidsoap
/tmp/makepkg/liquidsoap/src/liquidsoap-1.2.0-full/liquidsoap-1.2.0/../ocaml-ffmpeg-0.1.1/src/libffmpeg_stubs.a(avutil_stubs.o): In function `caml_avutil_bits_per_pixel':
avutil_stubs.c:(.text+0x66): undefined reference to `av_pix_fmt_descriptors'
collect2: error: ld returned 1 exit status
File "caml_startup", line 1:
Error: Error during linking
../Makefile.rules:109: recipe for target 'liquidsoap' failed

leonardder commented on 2016-03-22 08:09

I've changed ffmpeg dependency to ffmpeg2.8. Please let me know whether compilation works again. I currently don't have enough spare time to test myself.