Package Details: liri-shell-git v0.9.0.r421.g5017cda1-1

Git Clone URL: https://aur.archlinux.org/liri-shell-git.git (read-only, click to copy)
Package Base: liri-shell-git
Description: QtQuick and Wayland based shell for convergence
Upstream URL: https://liri.io
Licenses: GPL3
Groups: liri-git
Conflicts: hawaii-shell-git, liri-shell, liri-workspace-git, papyros-shell-git
Provides: liri-shell
Replaces: hawaii-shell-git, liri-shell, liri-workspace-git, papyros-shell-git
Submitter: plfiorini
Maintainer: plfiorini (Terence, Aldrog)
Last Packager: plfiorini
Votes: 24
Popularity: 0.000032
First Submitted: 2016-10-13 19:38
Last Updated: 2019-10-15 20:11

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

cpatrick08 commented on 2015-06-05 17:18

could you remove qml-desktop-git on list of depends as it is no longer on papyros github account

LeonardK commented on 2015-03-10 20:43

With "weston itself" I meant running weston standalone from the tty (weston-launch). That's why I'm a bit curious why "hawaii-session --mode=nested" won't run as it - as you said, spawns weston.

plfiorini commented on 2015-03-10 20:39

thanks for reporting anyway

plfiorini commented on 2015-03-10 20:39

hawaii-session spawns weston (with fullscreen shell plugin) process itself, could it be that i miss something?

works on intel drivers though.

another weird issue i noticed: weston from gdm runs perfectly, hawaii-session not, weston complains about permissions even though logind creates the session. maybe i have to pass something to the weston process, but i'm not sure what.

LeonardK commented on 2015-03-10 20:32

yep, missed that.

A bit strange though:
I can run weston alone from tty, but when starting hawaii-shell --mode=nested
it just seems to hang at loading module /usr/lib/weston/gl-renderer.so.

Could be because I'm on the proprietary drivers from nVidia, though I'm a bit curious why weston itself runs properly.
Maybe I'll try the next days with nouveau. Thanks for updating the PKGBUILDs ;-)

plfiorini commented on 2015-03-10 20:16

Done except that pam is not optional (otherwise lock screen authentication won't work)

LeonardK commented on 2015-03-10 18:46

additionally you should add pam to the optional dependencies

LeonardK commented on 2015-03-10 18:43

please move hawaii-icon-themes-git and hawaii-wallpapers-git to the optional dependencies.

garydelaney commented on 2015-02-14 21:30

Using this git command in pkgver() is working for me.

printf "%s.%s" "$(git describe --abbrev=0 --tags | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g')" "$(git rev-list --count HEAD)"

This gives an upgrade with the newest revision of the current tag.

asonix commented on 2015-02-13 15:37

@gld1982ltd

I'll look into it.