Package Details: llvm50-libs 5.0.2-6

Git Clone URL: https://aur.archlinux.org/llvm50.git (read-only, click to copy)
Package Base: llvm50
Description: Low Level Virtual Machine (runtime libraries)
Upstream URL: http://llvm.org/
Licenses: custom:University of Illinois/NCSA Open Source License
Submitter: SolarAquarion
Maintainer: SolarAquarion (kgizdov)
Last Packager: kgizdov
Votes: 5
Popularity: 0.000001
First Submitted: 2017-11-19 18:17
Last Updated: 2018-10-14 23:26

Latest Comments

1 2 3 Next › Last »

gnaggnoyil commented on 2020-07-16 12:32

This package fails to build due to API breaking changes made to struct ipc_perm since glibc 2.30. Please add patches regarding line 1154 of src file projects/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cc to fix this problem.

kaptoxic commented on 2019-02-08 19:27

Fails for me:

CMake Error at cmake/config-ix.cmake:306 (message):
libffi includes are not found.

kgizdov commented on 2018-10-14 13:59

@JP-Ellis, yeah, 'ocaml_doc' is only enabled if ocaml-ctypes is installed. Since this package doesn't include the OCaml bindings anyway, I've disable it.

JP-Ellis commented on 2018-10-09 03:57

Unfortunately, this PKGBUILD fails for me. In particular, I'm unable to complete the make ocaml_doc step as it errors with:

make: *** No rule to make target 'ocaml_doc'.  Stop.

After commenting out that step, everything works fine. Note that I do not have ocaml installed.

kgizdov commented on 2018-10-07 19:28

@SolarAquarion, I think should do it. thanks

SolarAquarion commented on 2018-10-06 13:31

@kgizdov i added you as a co-maintainer

SolarAquarion commented on 2018-10-05 15:59

I didn't see that patch unfortunately, lol

kgizdov commented on 2018-10-05 15:35

patch is here

kgizdov commented on 2018-10-05 15:29

With the patch, which I took from the official gcc6 package, you can compile with the current ver of glibc. Thus you don't need to recompile glibc itself. It's only a small header fix. Isn't that better than requiring a completely separate glibc?

SolarAquarion commented on 2018-10-05 14:22

It's actually needs a old version of glibc but the question is which version