Package Details: lm32-elf-binutils 2.30-1

Git Clone URL: https://aur.archlinux.org/lm32-elf-binutils.git (read-only)
Package Base: lm32-elf-binutils
Description: GNU binary utilities for the lm32-elf target.
Upstream URL: https://www.gnu.org/software/binutils/
Licenses: GPL
Submitter: cyrozap
Maintainer: cyrozap
Last Packager: cyrozap
Votes: 0
Popularity: 0.000000
First Submitted: 2016-03-13 04:30
Last Updated: 2018-06-10 09:57

Latest Comments

Lacsapix commented on 2018-05-31 11:49

The build fails with an "This statement may fall through [-Werror=implicit-fallthrough=]" Error.

Apparently this is something related to GCC >7.

https://developers.redhat.com/blog/2017/03/10/wimplicit-fallthrough-in-gcc-7/

EDIT: changing to 2.30 worked like a charm.

replace this lines:

_pkgver=2.26

with

_pkgver=2.30

and these three:

sha256sums=('c2ace41809542f5237afc7e3b8f32bb92bc7bc53c6232a84463c423b0714ecd9'

        '1c423c52a0a7121ae0bdc9ca01fd229fce03a87a0d9a6a899896aee7c8fe63b5')

validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93')

with

sha256sums=('efeade848067e9a03f1918b1da0d37aaffa0b0127a06b5e9236229851d9d0c09'

        '2fddd2a1d8c42ff9ed86bbac673dc8bf65fb305d452bb8f7fee69275a9ad278d')

validpgpkeys=('3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F')