Package Details: lmms-beta 1.2.0_rc6-3

Git Clone URL: https://aur.archlinux.org/lmms-beta.git (read-only)
Package Base: lmms-beta
Description: Beta version of the Linux MultiMedia Studio.
Upstream URL: https://lmms.io/
Keywords: beta lmms
Licenses: GPL
Conflicts: lmms, lmms-extras
Provides: lmms, lmms-extras
Submitter: Bleuzen
Maintainer: Bleuzen
Last Packager: Bleuzen
Votes: 2
Popularity: 0.391823
First Submitted: 2017-10-10 13:42
Last Updated: 2018-08-03 17:35

Dependencies (27)

Required by (2)

Sources (0)

Latest Comments

agapito commented on 2017-12-22 19:40

Thanks, it's working again. You should remove qt4 from dependencies.

Bleuzen commented on 2017-12-22 15:12

I got it working now. I fixed the packaging by (re)moving files. This is not the perfect solution, but it works for now.

I also found out how to 'fix' the VST GUI bug. You have to set "Plugin Embedding" in LMMS settings to "Embed using Qt API". With the default setting, "Embed using XEmbed protocol" it doesn't work.

So I think I can update the package now. Happy testing ;)

agapito commented on 2017-12-22 13:58

In theory, vst gui bug has been fixed before rc5 was released:

https://github.com/LMMS/lmms/commit/7c71bc657c34b2722f247e4820000c5e46f4d05f

Bleuzen commented on 2017-12-20 20:26

There is currently a problem building rc5 with this PKGBUILD. It generates files in my home directory and in /usr/lib64, that can't be installed. I have no idea how to fix this currently.

Also there is (still) a bug when using Qt5 + LMMS 1.2.0-rc5: The VST plugin GUIs don't work. But they work with the current PKGBUILD version (1.2.0-rc4 with qt4). I don't want to make new Qt4 builds anymore, since this should be fixed on LMMS side already. I don't know if this is still a LMMS bug or something with wine. I will try to figure it out...

I'm not sure if I should update this PKGBUILD to rc5 with these bugs. I think I will keep rc4 for some time. Maybe there will be fixes soon.

If you want to try out the newest version, rc5, you can download the AppImage here: https://github.com/LMMS/lmms/releases/download/v1.2.0-rc5/lmms-1.2.0-rc5-linux-x86_64.AppImage Warning: The AppImage version also has this VST GUI bug, so don't use it, if you use VST plugins!

Bleuzen commented on 2017-10-16 16:29

Hi @Oczkins92
Yes, the newest version has the vst vestige plugin.

Oczkins92 commented on 2017-10-16 16:13

Does has a vst vestige support?