Package Details: lmms-qt5-git 1.2.0.rc5.r53.gd65fdd4ee-1

Git Clone URL: https://aur.archlinux.org/lmms-qt5-git.git (read-only)
Package Base: lmms-qt5-git
Description: The Linux MultiMedia Studio (Qt5 Version).
Upstream URL: http://lmms.io
Keywords: DAW LMMS midi multimedia music
Licenses: GPL
Conflicts: lmms, lmms-git
Provides: lmms
Submitter: liushuyu
Maintainer: liushuyu
Last Packager: liushuyu
Votes: 15
Popularity: 2.474359
First Submitted: 2016-03-19 10:56
Last Updated: 2018-04-23 22:30

Dependencies (30)

Required by (1)

Sources (1)

Latest Comments

agapito commented on 2018-03-03 13:03

This PKGBUILD works: https://pastebin.com/NcbEvDFF

hellomiles commented on 2017-12-30 03:21

@dariost, I'm having the same issue. After some debugging I was able to get the package to build and install successfully by adding the following option to the cmake command in the build() function in the PKGBUILD:

-DCMAKE_INSTALL_LIBDIR=/usr/lib

dariost commented on 2017-12-23 13:48

Thanks for fixing those errors, but now there's another one:

$ sudo pacman -U lmms-qt5-git-1.2.0.rc5.r5.ga3d72def4-1-x86_64.pkg.tar.xz

loading packages...

resolving dependencies...

looking for conflicting packages...

Packages (1) lmms-qt5-git-1.2.0.rc5.r5.ga3d72def4-1

Total Installed Size: 159.97 MiB

:: Proceed with installation? [Y/n]

(1/1) checking keys in keyring

(1/1) checking package integrity

(1/1) loading package files

(1/1) checking for file conflicts

error: failed to commit transaction (conflicting files)

lmms-qt5-git: /usr/lib64 exists in filesystem

Errors occurred, no packages were upgraded.

liushuyu commented on 2017-12-23 08:08

dariost: All problems indicated have been fixed, and upstream has fixed the problem that in Qt 5 build, VST GUI may mess up.

As one of the LMMS developers, I am pleased to let you know that LMMS has completely switched to Qt 5 and all known problems relating to Qt 5 have been resolved.

Thanks!

safocl commented on 2017-12-14 02:46

liushuyu: да, вроде все нормально должно быть теперь

yes, everything seems to be fine now

dariost commented on 2017-12-13 14:57

There are currently 2 problems:

first, the version indicated on PKGBUILD is wrong (it says 1.2.0.rc4.r252.g3660ac9a6-1, but as of writing lmms has reached 1.2.0.rc4.r61.g54be88f53-1), so even after updating it says that the package is outdated

second, weakjack.so gets created as root (i don't know how this is possible, but it happens), so it generates all kind of problems. Disabling it (which does not disable jack support) with -DWANT_WEAKJACK=OFF solved the problem

liushuyu commented on 2017-12-13 08:25

safocl:

Hi, as I mentioned in earlier comment, the problem should have been fixed. Give it a try.

Google translated: перевод Google: Привет, как я уже упоминал в предыдущем комментарии, проблема должна быть исправлена. Попробуйте.

liushuyu commented on 2017-12-13 08:22

MaximusHome:

Hi, sorry for the late response, I have fixed that problem now. It should be good to go.

Note that LMMS now recommends Ninja as preferred build tool, so I made this change in this update, if you or anyone else notice any build problems, just let me know or open an issue at https://github.com/LMMS/lmms/issues/new

Thanks, liushuyu

liushuyu commented on 2017-12-13 08:20

funkmuscle: Hi, sorry for the super late response, I was really busy these days due to school work, I know this shouldn't be a valid excuse.

So I have fixed the build, the problem was LMMS now uses git sub-modules and we need to clone them all beforehand.

Thanks

MaximusHome commented on 2017-12-07 10:57

add cd -- "$srcdir/$_pkgname" into prepare()

All comments