Package Details: lombok-eclipse-java 1.18.24-1

Git Clone URL: https://aur.archlinux.org/lombok.git (read-only, click to copy)
Package Base: lombok
Description: Project Lombok integrated with several Eclipse-based installations
Upstream URL: https://projectlombok.org
Keywords: eclipse j2ee java jee lombok spring-tool-suite sts
Licenses: MIT
Submitter: Musikolo
Maintainer: Musikolo
Last Packager: Musikolo
Votes: 3
Popularity: 0.035848
First Submitted: 2020-07-05 02:44 (UTC)
Last Updated: 2022-05-06 21:30 (UTC)

Dependencies (3)

Required by (0)

Sources (1)

Pinned Comments

Musikolo commented on 2020-07-05 03:16 (UTC) (edited on 2021-10-14 02:40 (UTC) by Musikolo)

README

If you're using Eclipse, please read Lombok issue #1820 to learn how to work around it.

Latest Comments

rozarh commented on 2022-06-21 07:28 (UTC)

I installed it manually (git clone... etc)

rozarh commented on 2022-06-21 07:19 (UTC)

[rozarh@bastet ~]$ pamac build lombok-common Preparing... Cloning lombok build files... Generating lombok-common information... ==> ERROR: PKGBUILD does not exist. Error: Failed to prepare transaction: Failed to generate lombok-common information

WHY???

Musikolo commented on 2022-05-06 21:30 (UTC)

Upgraded to version 1.18.24.

Enjoy!

Musikolo commented on 2021-10-14 02:40 (UTC)

Updated to version 1.18.22.

Enjoy!

Musikolo commented on 2021-08-19 12:38 (UTC) (edited on 2021-08-24 01:07 (UTC) by Musikolo)

@Alukand, eclipse is installed under the usr/lib/eclipse directory. You can see that at https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=eclipse-jee#n25 and https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=eclipse-java#n25

Can you please confirm which eclipse flavor you're using?

Thanks.

Alukard commented on 2021-08-18 06:47 (UTC)

getting Can't find any IDE at: /usr/lib/eclipse/

why this is not looking in /opt directory ?

Musikolo commented on 2021-05-30 00:13 (UTC)

Updated to version 1.18.20.

Enjoy!

Musikolo commented on 2020-07-05 03:16 (UTC) (edited on 2021-10-14 02:40 (UTC) by Musikolo)

README

If you're using Eclipse, please read Lombok issue #1820 to learn how to work around it.