Package Details: lombok-eclipse 1.18.0-2

Git Clone URL: https://aur.archlinux.org/lombok-eclipse.git (read-only)
Package Base: lombok-eclipse
Description: Project Lombok integrated to Eclipse installation
Upstream URL: http://projectlombok.org
Licenses: MIT
Submitter: someoneelse123
Maintainer: None
Last Packager: haawda
Votes: 4
Popularity: 0.116789
First Submitted: 2012-08-25 15:23
Last Updated: 2018-06-17 00:35

Latest Comments

stas-t commented on 2018-06-17 13:19

Now lobmok-eclipse is not compatible with eclipse-jee anymore:

eclipse-java and eclipse-jee are in conflict (eclipse). Remove eclipse-jee? [y/N]

fsteccanella commented on 2018-06-12 14:30

Cannot build due to invalid sha256 hashsum. Will flag out-of-date.

stonekyx commented on 2017-07-07 01:50

Cannot build due to invalid sha256 hashsum. Will flag out-of-date.

BluePeril commented on 2015-07-28 17:05

Thank you for the hint. I have fixed it

PhCl commented on 2015-07-28 12:43

It worked fine before Eclipse 4.5 Mars.

Now, since Arch has upgrade to Eclipse 4.5, the installation fails with the following error:

WARNING: Can't find any IDE at: /usr/share/eclipse
WARNING: Zero valid locations found; so nothing was done!
-------------------
You have to add /usr/share/eclipse/lombok.jar (or lombok-api).jar as 'external JAR'
to build path of each project which should use it
-------------------

Replacing "/usr/share/eclipse" by "/usr/lib/eclipse" in both the PKGBUILD and the install file seems to fix the problem.

someoneelse123 commented on 2014-06-03 13:52

I'm sorry, but I already ran away from Arch after systemd catastrophe and although I'm still trying to maintain my other packages, this one is little too problematic to test without actual Arch environment.

*disowned*