Package Details: looking-glass-git 2:B4.r63.gb8effaf4-1

Git Clone URL: https://aur.archlinux.org/looking-glass-git.git (read-only, click to copy)
Package Base: looking-glass-git
Description: A client application for accessing the LookingGlass IVSHMEM device of a VM
Upstream URL: https://looking-glass.io/
Licenses: GPL2
Conflicts: looking-glass
Provides: looking-glass
Submitter: Omar007
Maintainer: Omar007
Last Packager: Omar007
Votes: 12
Popularity: 0.162013
First Submitted: 2017-12-14 09:38
Last Updated: 2021-07-19 09:43

Latest Comments

1 2 3 Next › Last »

Netboy3 commented on 2021-07-23 12:16

You are correct. My bad.

Omar007 commented on 2021-07-20 09:02

@Netboy3; I'm not pulling/building against master submodules or otherwise diverting those definitions to commits not specified by upstream. Each git repo defines the submodule version/commit being used. That means (at the time of writing) for looking-glass it's using cimgui@83f729b (a.k.a. cimgui 1.82), which in turn uses imgui@64aab84 (1.82 + 2 extra). This isn't functioning any differently from the submodules it had already; PureSpice and LGMP.

Netboy3 commented on 2021-07-20 01:57

Thx for adding the new cimgui/imgui dependency. Only thing you should consider is that the devs are currently building against version 1.82 of cimgui/imgui and you are pulling cimgui master which seems to be quite active and might cause LG builds to break or be inconsistent with the way the LG devs use it.

Svenstaro commented on 2021-07-18 23:09

Working patch:

diff --git a/PKGBUILD b/PKGBUILD
index 8cf7662..5876f77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=("${_pkgname}-git"
          "${_pkgname}-host-git"
          "obs-plugin-${_pkgname}-git")
 epoch=2
-pkgver=B3.r236.g118d9a0
+pkgver=B4.r56.ge4e1451
 pkgrel=1
 pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
 url="https://looking-glass.io/"
@@ -17,8 +17,10 @@ makedepends=('cmake' 'git' 'fontconfig' 'spice-protocol' 'wayland-protocols'
              'libgl' 'libegl' 'libxss' 'libxi' 'libxinerama' 'obs-studio')
 source=("${_pkgname}::git+https://github.com/gnif/LookingGlass.git"
         "LGMP::git+https://github.com/gnif/LGMP.git"
-        "PureSpice::git+https://github.com/gnif/PureSpice.git")
+        "PureSpice::git+https://github.com/gnif/PureSpice.git"
+        "cimgui::git+https://github.com/cimgui/cimgui.git")
 sha512sums=('SKIP'
+            'SKIP'
             'SKIP'
             'SKIP')
 install="${pkgbase}.install"
@@ -36,7 +38,8 @@ prepare() {
    git submodule init
    git config submodule.repos/LGMP.url "${srcdir}/LGMP"
    git config submodule.repos/PureSpice.url "${srcdir}/PureSpice"
-   git submodule update
+   git config submodule.repos/cimgui.url "${srcdir}/cimgui"
+   git submodule update --init --recursive
 }

 build() {

Ghosthree3 commented on 2021-07-18 05:49

Latest commit(s) break build.

CMake Error at renderers/EGL/CMakeLists.txt:44 (add_library):
  Cannot find source file:

    /home/user/src/looking-glass-git/src/looking-glass/repos/cimgui/imgui/backends/imgui_impl_opengl3.cpp

  Tried extensions .c .C .c++ .cc .cpp .cxx .cu .mpp .m .M .mm .ixx .cppm .h
  .hh .h++ .hm .hpp .hxx .in .txx .f .F .for .f77 .f90 .f95 .f03 .hip .ispc


CMake Error at renderers/OpenGL/CMakeLists.txt:9 (add_library):
  Cannot find source file:

    /home/user/src/looking-glass-git/src/looking-glass/repos/cimgui/imgui/backends/imgui_impl_opengl2.cpp

  Tried extensions .c .C .c++ .cc .cpp .cxx .cu .mpp .m .M .mm .ixx .cppm .h
  .hh .h++ .hm .hpp .hxx .in .txx .f .F .for .f77 .f90 .f95 .f03 .hip .ispc


CMake Error at renderers/EGL/CMakeLists.txt:44 (add_library):
  No SOURCES given to target: renderer_EGL


CMake Error at renderers/OpenGL/CMakeLists.txt:9 (add_library):
  No SOURCES given to target: renderer_OpenGL


CMake Generate step failed.  Build files cannot be regenerated correctly.
==> ERROR: A failure occurred in build().

Builds successfully from --recursive cloned source independently.

Netboy3 commented on 2021-02-20 15:38

Dependency on glu was removed. Please see commit: https://github.com/gnif/LookingGlass/commit/2973319bff80bf1531265bdbec6707bdda3f40eb

xiretza commented on 2021-01-20 09:59

Now requires makedepends=('libxss') and depends=('libxss') in package_looking-glass-git(): https://github.com/gnif/LookingGlass/commit/8cb0cbb91d21f501d0c3ac367ba98ece284bd8e3

xiretza commented on 2021-01-17 16:39

requires makedepends=('wayland-protocols').

Netboy3 commented on 2020-08-07 16:32

Hi @Omar007. Now that the MinGW cross-compiler toolchain mingw-w64-gcc and all it's dependencies are available in the community repo, you might want to consider adding building the looking-glass Windows host executable to this package.

Omar007 commented on 2020-07-24 11:01

Ah that explains @rku's comment haha. I was looking at that from the perspective of what the module 'package' does without realizing an extra file was added that is needed for even DKMS to be able do its thing after the package is installed.

Pushing an update shortly.