Package Details: loqui 0.5.5-1

Git Clone URL: https://aur.archlinux.org/loqui.git (read-only)
Package Base: loqui
Description: IRC client for the Gtk+-2.0 environment
Upstream URL: https://launchpad.net/loqui
Licenses: GPL2
Submitter: None
Maintainer: Dragonlord
Last Packager: Dragonlord
Votes: 4
Popularity: 0.000000
First Submitted: 2006-09-03 19:55
Last Updated: 2015-06-28 15:38

Latest Comments

Anonymous comment on 2013-01-08 14:47

# Here's the edited PKGBUILD for 0.5.3
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>

pkgname=loqui
pkgver=0.5.3
pkgrel=1
pkgdesc="IRC client for the Gtk+-2.0 environment"
arch=('i686' 'x86_64')
url="https://launchpad.net/loqui"
license=('GPL2')
depends=('gtk2' 'glib2' 'gnet')
source=(http://launchpad.net/$pkgname/0.5/$pkgver/+download/$pkgname-$pkgver.tar.gz)
md5sums=('38176d42e0853990c4d7e6b25576ab44')

build() {
cd ${srcdir}/$pkgname-$pkgver

./configure --prefix=/usr
make
}

package() {
cd ${srcdir}/$pkgname-$pkgver

make DESTDIR=${pkgdir} install
}

Anonymous comment on 2013-01-08 14:46

I downloaded the 0.5.3 source, edited the PKGBUILD file (including the md5sum) and it worked. I don't know what the problem is with 0.5.2.

Anonymous comment on 2013-01-08 03:03

The build failed. Here's the last few lines of output:

make[4]: Entering directory `/home/ewl/Desktop/loqui/src/loqui-0.5.2/src'
/bin/sh ../libtool --tag=CC --mode=link gcc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wl,-O1,--sort-common,--as-needed,-z,relro -o loqui gtkutils.o main.o loqui_app_actions.o loqui_stock.o loqui_app.o loqui_app_info.o loqui_channel_entry_store.o loqui_channel_entry_action.o loqui_channel_buffer_gtk.o loqui_dropdown_box.o loqui_account_manager_store.o channel_tree.o nick_list.o about.o account_list_dialog.o loqui_statusbar.o prefs_dialog.o loqui_channel_text_view.o command_dialog.o remark_entry.o loqui_channelbar.o loqui_select_dialog.o prefs_general_upgrader.o loqui-core-gtk.o loqui-style-entry.o loqui-account-dialog.o loqui-protocol-selection-dialog.o loqui-transfer-window.o loqui-tray-icon.o loqui-channel-entry-action-group.o loqui-channel-entry-ui-data.o loqui-channel-entry-action-group-ui.o loqui-notifier-gtk.o -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 ../libloqui/libloqui.la
libtool: link: gcc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z -Wl,relro -o loqui gtkutils.o main.o loqui_app_actions.o loqui_stock.o loqui_app.o loqui_app_info.o loqui_channel_entry_store.o loqui_channel_entry_action.o loqui_channel_buffer_gtk.o loqui_dropdown_box.o loqui_account_manager_store.o channel_tree.o nick_list.o about.o account_list_dialog.o loqui_statusbar.o prefs_dialog.o loqui_channel_text_view.o command_dialog.o remark_entry.o loqui_channelbar.o loqui_select_dialog.o prefs_general_upgrader.o loqui-core-gtk.o loqui-style-entry.o loqui-account-dialog.o loqui-protocol-selection-dialog.o loqui-transfer-window.o loqui-tray-icon.o loqui-channel-entry-action-group.o loqui-channel-entry-ui-data.o loqui-channel-entry-action-group-ui.o loqui-notifier-gtk.o -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgthread-2.0 -lrt ../libloqui/.libs/libloqui.a -lgio-2.0 -lgobject-2.0 -lglib-2.0 -pthread
/usr/bin/ld: ../libloqui/.libs/libloqui.a(loqui-core.o): undefined reference to symbol 'g_thread_init'
/usr/bin/ld: note: 'g_thread_init' is defined in DSO /usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libgthread-2.0.so so try adding it to the linker command line
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libgthread-2.0.so: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[4]: *** [loqui] Error 1
make[4]: Leaving directory `/home/ewl/Desktop/loqui/src/loqui-0.5.2/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/ewl/Desktop/loqui/src/loqui-0.5.2/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/ewl/Desktop/loqui/src/loqui-0.5.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ewl/Desktop/loqui/src/loqui-0.5.2'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

vinzv commented on 2011-11-21 22:08

New version -> source: http://launchpad.net/loqui/0.5/0.5.2/+download/loqui-0.5.2.tar.gz / md5sum: 6d026d10a68c5c8429bf7571d35fbf14

vinzv commented on 2011-11-21 22:05

New version: 0.5.2 -> http://launchpad.net/loqui/0.5/0.5.2/+download/loqui-0.5.2.tar.gz

dumblob commented on 2010-09-23 13:13

Hi, could you please add the 'x86_64' entry in the arch array? It is fully functional.
Thank you in advance.