Package Details: loupe-git 46.rc.r84.ge458872-1

Git Clone URL: https://aur.archlinux.org/loupe-git.git (read-only, click to copy)
Package Base: loupe-git
Description: simple image viewer for GNOME
Upstream URL: https://gitlab.gnome.org/GNOME/loupe
Keywords: adwaita gnome image incubator new viewer
Licenses: GPL-3.0-or-later
Conflicts: loupe
Provides: loupe
Submitter: flipflop97
Maintainer: TrialnError
Last Packager: TrialnError
Votes: 11
Popularity: 0.012027
First Submitted: 2022-04-06 16:09 (UTC)
Last Updated: 2024-06-08 20:58 (UTC)

Latest Comments

yochananmarqos commented on 2023-06-09 22:06 (UTC) (edited on 2023-06-09 22:07 (UTC) by yochananmarqos)

No idea what the point of this package is. No one should be using development packages on a normal system. There's now a new library being used. See https://thisweek.gnome.org/posts/2023/06/twig-99/#loupe

If you really want to test and help with development, use GNOME OS or nightly Flatpaks.

cirlo commented on 2023-03-11 09:44 (UTC)

Now that gtk4 got updated to 4.10, the problem is the constraint on libadwaita>=1.2.99 :\

flipflop97 commented on 2023-02-10 13:54 (UTC)

You can try gtk4-git or the FCGU repo (which also includes Loupe pre-built).

eboye commented on 2023-02-10 02:45 (UTC)

@gnacho I don't think so. The only solution is that that package get's updated, and that version is marked as unstable on gtk website: https://www.gtk.org/

So I don't think it's coming in aur soon enough.

gnacho commented on 2023-02-08 08:15 (UTC)

Any solution to the problem dependency? -> gtk4>=1:4.9.0

hemish commented on 2023-01-16 11:58 (UTC)

Build fails, because the app is using unstable gtk 4.9 whereas stable version is at 4.8.3 only, so arch repos have 4.8.3, whereas gtk rust package is saying it needs 4.9.

gnacho commented on 2022-09-03 13:21 (UTC)

It's failing in a fresh Manjaro Os:

  cargo:warning=`"pkg-config" "--libs" "--cflags" "libadwaita-1" "libadwaita-1 >= 1.2.alpha"` did not exit successfully: exit status: 1
  error: could not find system library 'libadwaita-1' required by the 'libadwaita-sys' crate

  --- stderr
  Package dependency requirement 'libadwaita-1 >= 1.2.alpha' could not be satisfied.
  Package 'libadwaita-1' has version '1.1.4', required version is '>= 1.2.alpha'

warning: build failed, waiting for other jobs to finish...
[3/4] Generating data/org.gnome.Loupe.desktop with a custom command
FAILED: src/loupe 
/usr/bin/env CARGO_HOME=/var/tmp/pamac-build-nacho/loupe-git/src/build/cargo-home /usr/bin/cargo build --manifest-path /var/tmp/pamac-build-nacho/loupe-git/src/loupe/Cargo.toml --target-dir /var/tmp/pamac-build-nacho/loupe-git/src/build/src --release && cp src/release/loupe src/loupe
ninja: build stopped: subcommand failed.
==> ERROR: Se produjo un fallo en build().
    Cancelando...