Package Details: lowdown 0.4.2-1

Git Clone URL: https://aur.archlinux.org/lowdown.git (read-only)
Package Base: lowdown
Description: Markdown translator producing HTML5 and roff documents in the ms and man formats
Upstream URL: https://kristaps.bsd.lv/lowdown/
Keywords: library markdown processor
Licenses: custom:BSD
Submitter: aperez
Maintainer: aperez
Last Packager: aperez
Votes: 0
Popularity: 0.000000
First Submitted: 2017-10-24 15:47
Last Updated: 2019-02-28 18:20

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

aperez commented on 2018-08-25 08:53

@kseistrup: Permissions here are the expected 0755 and 0644, this is what I can currently see in my system with the latest versions of the packages installed:

% ls -l /usr/bin/lowdown{,-diff} /usr/lib/lib{diff,lowdown}.a 
-rwxr-xr-x 1 root root 112648 ago 24 14:59 /usr/bin/lowdown*
-rwxr-xr-x 1 root root 112648 ago 24 14:59 /usr/bin/lowdown-diff*
-r--r--r-- 1 root root  38120 ago 24 17:32 /usr/lib/libdiff.a
-rw-r--r-- 1 root root 191764 ago 24 14:59 /usr/lib/liblowdown.a
%

Could it be that you have your umask changed to some non-default value?

kseistrup commented on 2018-08-25 07:15

PS: I believe the guy behind lowdown/libdiff does something we don't do on Arch: He installs executable files as 0555 (we usually use 0755) and other files as 0444 (we usually use 0644).

kseistrup commented on 2018-08-25 07:10

Thanks, @aperez.

aperez commented on 2018-08-24 12:39

I've pushed the update to version 0.4.0 a moment ago.

@kseistrup Thanks for the heads up about libdiff! I got a PKGBUILD for that done as well :-)

kseistrup commented on 2018-08-24 08:35

Please note that v0.4.0+ requires libdiff ⌘ https://github.com/kristapsdz/libdiff