Package Details: lprof

Git Clone URL: (read-only)
Package Base: lprof
Description: Imaging device calibration tool
Upstream URL:
Licenses: GPL
Submitter: seidler2547
Maintainer: seidler2547
Last Packager: seidler2547
Votes: 2
Popularity: 0.396072
First Submitted: 2015-12-21 12:24
Last Updated: 2016-06-26 19:38

Dependencies (5)

Required by (0)

Sources (3)

Latest Comments

zephrax commented on 2016-05-20 12:36

Confirm. I had to edit the PKGBUILD to be able to compile it.

==> ERROR: license should be an array
==> ERROR: Makepkg was unable to build .
==> Restart building lprof ? [y/N]
==> ------------------------------
==> y

ahxxm commented on 2016-04-10 10:41

confirm, please add paren to "GPL" :)

ackthet commented on 2016-03-16 12:29

I can confirm.

hrniels commented on 2016-03-04 19:33

There is a small mistake in the PKGBUILD. My makepkg (5.0.1) compains that "license should be an array". Apart from this, everything worked fine.

davspace commented on 2016-02-01 04:42

The install works :)

I will test tonight the application.
Python3 is my default package, can it be an issue ?

Thks seidler !

seidler2547 commented on 2016-01-31 20:15

Ok, I have reproduced both issues in a clean Arch environment and updated the package. It should build now, but there might be issues with python2 vs. python(3) that I did not test (i.e. if python3 is your default python).

So please try again and let me know the results :)

davspace commented on 2016-01-31 11:18

I have this error with yaourt :

scons: *** [/tmp/yaourt-tmp-jedi/aur-lprof/pkg/lprof/usr/share/lprof/data/translations/lprof_de.qm] Source `data/translations/lprof_de.qm' not found, needed by target `/tmp/yaourt-tmp-jedi/aur-lprof/pkg/lprof/usr/share/lprof/data/translations/lprof_de.qm'.

Any help ?

seidler2547 commented on 2016-01-30 21:47

Yeah, I know I had to do some trickery in the build scripts (hence the patch for it) to get it to recognise where qt3 is. Are you using yaourt, pacaur or plain makepkg? I'll try to build this on a newly installed Arch VM tomorrow and see what must be improved.

wombalton commented on 2016-01-30 15:29

I'm getting some errors while installing:
scons: warning: The Options class is deprecated; use the Variables class instead.
File "/tmp/makepkg/lprof/src/lprof-", line 14, in <module>

scons: warning: The PathOption() function is deprecated; use the PathVariable() function instead.
File "/tmp/makepkg/lprof/src/lprof-", line 15, in <module>
Checking for Qt at /usr... no
QT directory not valid. Failed QT test build.
Failed to find valid QT environment.

I have qt3, qt4 and qt5 installed!

Maybe that qt_directory must be set to something else, but I can't find the thing in the man page

Any help?