Package Details: lua-posix 34.1.1-3

Git Clone URL: https://aur.archlinux.org/lua-posix.git (read-only, click to copy)
Package Base: lua-posix
Description: POSIX bindings for Lua
Upstream URL: https://github.com/luaposix/luaposix
Licenses: MIT
Submitter: wookietreiber
Maintainer: cafehaine (caleb, hoelzro)
Last Packager: caleb
Votes: 10
Popularity: 0.119852
First Submitted: 2016-11-08 14:03
Last Updated: 2020-03-01 05:27

Dependencies (5)

Sources (1)

Pinned Comments

caleb commented on 2020-02-21 05:07

PSA: I've started hosting this, all its dependencies, and also many other Lua Rocks packages as prebuilt packages in my repository for those that want to install them using pacman without messing around with building from the AUR.

Latest Comments

1 2 Next › Last »

caleb commented on 2020-02-21 05:07

PSA: I've started hosting this, all its dependencies, and also many other Lua Rocks packages as prebuilt packages in my repository for those that want to install them using pacman without messing around with building from the AUR.

caleb commented on 2020-02-21 04:37

Thanks for the heads up @bartus, I've corrected that.

bartus commented on 2020-02-19 18:42

makedepends is missing lua5{1,2} interpeters.

extra-x86_64-build

==> Starting package_lua52-posix()...                                                
Warning: Lua 5.2 interpreter not found at /usr                                       

Modules may not install with the correct configurations. You may want to specify the path prefix to your build of Lua 5.2 using --lua-dir
sh: line 1: /usr/bin/lua5.2: No such file or directory                                                                                                                    

Error: Build error: Failed building.
diff --git a/PKGBUILD b/PKGBUILD
index a4fed9b..c863129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgdesc="POSIX bindings for Lua"
 arch=('i686' 'x86_64')
 url="https://github.com/$_pkgbase/$_pkgbase"
 license=('custom')
-makedepends=('luarocks')
+eval makedepends=('lua' "lua5{1,2}" 'luarocks')
 _lua_deps=('std-normalize')
 source=("$_pkgbase-$pkgver.tar.gz::https://github.com/$_pkgbase/$_pkgbase/archive/release-v$pkgver.tar.gz")
 sha256sums=('273df2dbd9581a2f22e4265f14d0d759c487c0c9830f94395d7d690474382810')

caleb commented on 2020-02-12 17:31

@hoelzro Thanks ... by the way I see you've been added as a maintainer of the lua-posix package, so we're just waiting for the deletion request to go through here then we can enable the lua51-posix sub-package same in the PKGCONFIG there.

hoelzro commented on 2020-02-12 17:14

@caleb Sounds good, thanks for the heads-up!

caleb commented on 2020-02-12 09:33

Thanks @cafehoine. I've updated the package and have it all setup to produce the other packages, but the AUR names are blocked right now. I filed deletion requests for them. One of them I own so that should be pretty straightforward, it just has to get approved. The other is currently owned by @hoelzro. You might consider adding him as another co-maintainer as a token of thanks and to allow him to version bump something he was obviously interested in.

As soon as the other packages are deleted all we need to do is enable the pkgname(s) for them (currently commented out).

caleb commented on 2020-02-12 09:29

I have setup the lua-posix package ready to produce sub-packages for lua52 and lua51. I'm going to submit a deletion request for this so the package base name is not blocked in the AUR. Just FYI.

cafehaine commented on 2020-02-12 08:49

Just added you as a co-maintainer, you're free to try creating that PKGBUILD :) Send me an email if you want to talk about it

caleb commented on 2020-02-12 08:46

I've just adopted the 2years OOD lua52-posix package, but really what I think should happen is this package should be a base package that provides Lua 5.3, 5.2, and 5.1 sub-packages. Would you mind adding me as a co-maintainer to set that up?

cafehaine commented on 2018-10-25 10:26

Seems to work for me, are you testing with lua 5.3 ?