Package Details: lua51-cd 5.11.1-1

Git Clone URL: https://aur.archlinux.org/libcd.git (read-only)
Package Base: libcd
Description: Lua (5.1) bindings for Canvas Draw library
Upstream URL: http://www.tecgraf.puc-rio.br/cd/
Licenses: MIT
Submitter: None
Maintainer: blueowl
Last Packager: blueowl
Votes: 5
Popularity: 0.458155
First Submitted: 2010-07-22 08:52
Last Updated: 2018-04-25 13:07

Latest Comments

1 2 Next › Last »

ktamp commented on 2018-08-27 23:29

Please add 'lua' to makedepends. This would solve potential problems on systems where 'lua' is not already installed and pikaur AUR helper is used (possibly others too).

quipa commented on 2018-08-10 19:45

There seems to be an issue with the md5sums for ftgl, getting the following error:

==> Validating source files with md5sums...
    cd-5.11.1_Sources.tar.gz ... Passed
    ftgl-2.1.5_Sources.tar.gz ... FAILED
    cd-5.11.1_Docs.pdf ... Passed
==> ERROR: One or more files did not pass the validity check!

blueowl commented on 2018-04-25 13:13

ktamp commented on 2018-03-05 21:21

Please add 'lsb-release' to Makedepends list. Maybe remove 'glu' from Makedepends list? It is already in Depends list. Any reason for not updating to v5.11.1? It has been out for 8 months now.

haawda commented on 2017-06-06 05:50

The ??? seems to be the kernel version number. So this PKGBUILD produces different packages when built under linux-lts. Great idea.

ktamp commented on 2017-05-14 13:19

Please replace Linux??_?? with Linux???_??.

daurnimator commented on 2017-01-30 14:44

/usr/lua/5.1 is the wrong location. It should be /usr/lib/lua/5.1

catwell commented on 2017-01-09 17:49

The fix is to replace this line:

make || true

with:

make FLAGS="-I/usr/include/im" LFLAGS="-L/usr/lua/5.1" || true

Also, on my system, Linux48_64 should be replaced by Linux46_64.

daurnimator commented on 2016-12-16 03:10

Requires dependency on libim?
I think this commit broke this package: https://aur.archlinux.org/cgit/aur.git/commit/?h=libcd&id=765d0044d600c9be23913d38baee7872239a1d75

Tecmake: compiling cdim.c ...
gcc -c -Wall -O2 -m64 -fPIC -I. -I../include -I../../im/include -DTEC_UNAME=Linux48_64 -DTEC_SYSNAME=Linux -DLinux=4.8 -DTEC_LITTLEENDIAN -DTEC_64 -DFUNCPROTO=15 -DNDEBUG -o ../obj/cdim/Linux48_64/cdim.o drv/cdim.c
drv/cdim.c:14:16: fatal error: im.h: No such file or directory
#include <im.h>
^
compilation terminated.
make[2]: *** [../tecmake.mak:1647: ../obj/cdim/Linux48_64/cdim.o] Error 1
make[1]: *** [Makefile:21: cdim] Error 2
make: *** [Makefile:4: do_all] Error 2

daurnimator commented on 2016-11-07 05:16

cdcontextplus not built?