Package Details: lua51-dkjson 2.5-4

Git Clone URL: https://aur.archlinux.org/lua-dkjson.git (read-only, click to copy)
Package Base: lua-dkjson
Description: David Kolf’s Pure Lua JSON module with UTF-8 support and no external dependencies
Upstream URL: http://dkolf.de/src/dkjson-lua.fsl/home
Licenses: MIT
Submitter: masterkorp
Maintainer: caleb
Last Packager: caleb
Votes: 4
Popularity: 0.002579
First Submitted: 2013-03-16 23:25
Last Updated: 2020-08-06 09:18

Dependencies (6)

Required by (1)

Sources (1)

Latest Comments

caleb commented on 2020-08-10 22:11

@raxod501 That's because you're missing dependencies. Please install lua53. If that package hasn't hit Manjaro yet please talk to Manjaro folks, the default Lua on Arch Linux is 5.4 now and all the 5.3 stuff is under a the versioned package names. You have to have all the versions of Lua to build because this builds module packages for all the Lua's available in Arch. You don't have to have that to use the package, only to build.

raxod502 commented on 2020-08-10 21:25

The build fails for me on Manjaro with the following output:

==> Making package: lua-dkjson 2.5-4 (Mon 10 Aug 2020 03:12:56 PM MDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Missing dependencies:
  -> lua53

Stephen304 commented on 2020-02-21 15:49

Hey @caleb, tbh I don't know much about lua (I just needed a bunch of 5.1 packages at the time) so feel free to take over this one and do as you see fit.

caleb commented on 2020-02-21 10:37

Hey Stephen304 I've recently inherited the lua-dkjson package. I think it makes sense to expand that as the package base to cover Lua 5.1 and 5.2 as well, much the way you've set this package up to cover non 5.3 ;-) I've added you as a co-maintainer to that package, updated it to 2.5, and setup all the plumbing so it is ready to build 5.1 and 5.2 packages from. I also filed a merge request for this package.

Note a few things have changed since you packaged this, and notably there is now one luarocks that can handle packages for any Lua version, there is no such thing as luarocks5.1. It also has a --no-manifest flag so you don't have to monkey with deleting that. I think it should be pretty well setup for a smooth transition, but until this is deleted so the AUR namespace is open I can't enable the other two sub-packages. When this is merged and one of us enables the sub-packages, the pkgrel should also be bumped to obsolete people that have this iteration of the PKGBUILD.

caleb commented on 2020-02-06 05:25

I would like to fix this so that one base package generates corresponding packages for Lua 5.3, Lua 5.2, and Lua 5.1. Would you consider adding me as a maintainer?

(For example lua51-dkjson is required for lua51-busted, a package set I maintain. The other AUR package for lua51-dkson is broken in other ways and I think it would be better to fix it here with one base package.)

Ambrevar commented on 2015-05-21 05:50

Updated for Lua 5.3 and installs in the right folder.

hawk07 commented on 2015-05-17 08:05

Does't work with Lua 5.3

Ambrevar commented on 2015-02-17 13:12

The packaging policy is not compliant with Lua on Arch: being non-binary, the library should be installed to /usr/share/lua instead of /usr/lib/lua. It actually matters for luajit. Can you please change this? Thanks!

mszczepanczyk commented on 2013-10-27 11:35

New url: http://dkolf.de/src/dkjson-lua.fsl/raw/dkjson.lua?name=0b725e9e99117b71a1f62e921c98bf3327ac8809