Package Details: lua52-compat53 0.9-1

Git Clone URL: https://aur.archlinux.org/lua-compat53.git (read-only, click to copy)
Package Base: lua-compat53
Description: Compatibility module providing Lua-5.3-style APIs for Lua 5.2
Upstream URL: https://github.com/keplerproject/lua-compat-5.3
Keywords: compat lua
Licenses: MIT
Submitter: daurnimator
Maintainer: daurnimator
Last Packager: daurnimator
Votes: 4
Popularity: 1.37
First Submitted: 2018-09-23 15:51
Last Updated: 2020-07-09 13:21

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

daurnimator commented on 2020-07-09 13:25

@caleb, I'm not sure about including bit32 in this AUR package.... if anything it would end up as a split package as its not really part of the compat-5.3 core (but just mirrored in the same repository)

caleb commented on 2020-07-09 09:09

In order to support Lua 5.4 there have been a couple upstream releases, the latest of which bundle the bit32 module as well. I maintain the AUR packages for that but would be happy to file for deletion after this starts providing them. Alternatively I guess we could keep them as two separate packages and just exorcise it from this package so they don't conflict.

Either way I'd be interested in co-maintaining this too especially to help get the dust settled as 5.4 hits [community].