Package Details: lua52-iup 3.30-1

Git Clone URL: (read-only, click to copy)
Package Base: iup
Description: Lua 5.2 bindings for IUP GUI toolkit
Upstream URL:
Licenses: MIT
Submitter: None
Maintainer: daurnimator (blueowl)
Last Packager: blueowl
Votes: 12
Popularity: 0.018511
First Submitted: 2009-09-13 15:00 (UTC)
Last Updated: 2020-08-07 11:49 (UTC)

Dependencies (18)

Required by (0)

Sources (2)

Latest Comments

1 2 3 4 5 Next › Last »

blueowl commented on 2020-02-13 15:18 (UTC) (edited on 2020-02-13 15:20 (UTC) by blueowl)


I have found out what's the problem with not-running iupview. The issue was in libcd (which is an iup dependency).
It was linked with Gtk2 instead of Gtk3 (when built on Linux 5.x machine). I have fixed it now in libcd-5.12-3.
The update should fix your issues.

pauld commented on 2019-06-16 16:36 (UTC)

Just would like to say you can compile a C program with: gcc -I/usr/include/iup -liup -liupimglib -o hello hello.c

pauld commented on 2019-06-16 15:45 (UTC) (edited on 2019-06-16 17:27 (UTC) by pauld)

Been able to run Nim examples for iup module. But I have tried to run iupview and got that error: [paul@paul-pc iup]$ iupview

(iupview:20850): Gtk-ERROR **: 06:19:38.257: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported Trappe pour point d'arrêt et de trace (core dumped)

[Yeah, on Manjaro 18.0.4 (code name:Iliria) ]

Reading from: "GTK 3.x is supported. But the pre-compiled binaries, up to Linux 3.2, are still built with GTK 2.x." Unclear if iupview is a "pre-compiled binary".

pauld commented on 2019-06-16 09:12 (UTC) (edited on 2019-06-16 17:30 (UTC) by pauld)

Here on Manjaro, I had to had pangox-compat package for (libCD) to finish. Was blocking on -lpangox

Note that compiling webkitgtk take a few hours (for me on Quad Core computer). It is unclear to me if I could have installed webkit packages with pacman to avoid source compilation. [edit1] Might be because I installed iup with "pamac build iup", I seem to read that the -s in makepkg would try to install binary packages if available.[/edit1]

ktamp commented on 2019-03-12 21:37 (UTC)

Well... installation does work if you provide a tecmake.mak which knows about Linux5! ;)

(That is copying everything Linux4 to Linux5.)

daurnimator commented on 2018-08-28 05:18 (UTC)


Please add 'lua' 'lua51' and 'lua52' to makedepends list.


Maybe remove 'libcd', 'ftgl', 'webkitgtk', 'openmotif', 'libxpm' from Makedepends list? They are already in Depends list.

From man PKGBUILD:

Note that makepkg does not consider split package depends when checking if dependencies are installed before package building and with --syncdeps. All packages required to make the package are required to be specified in the global depends and makedepends arrays.

ktamp commented on 2018-08-27 23:26 (UTC)

Please add 'lua' 'lua51' and 'lua52' to makedepends list. They should be there.

Current behavior is to rely on: 1) Automatic installation of 'libcd' at the same time as 'iup'. 2) Not using an AUR helper which aggresively cleans up makedepends (e.g. pikaur). 3) Maybe having all these packages already installed in the system before building 'iup' (which would solve case 2).

ktamp commented on 2018-03-05 21:32 (UTC)

Maybe remove 'libcd', 'ftgl', 'webkitgtk', 'openmotif', 'libxpm' from Makedepends list? They are already in Depends list.

Maybe make 'lua-iup' (as well as 'lua-im' and 'lua-cd') optional? Keeping around three different versions of Lua may just be too much for someone interested in IUP but not in Lua. If necessary, Lua-less versions of the PKGBUILD's could be provided in addition to the existing ones.

daurnimator commented on 2017-11-08 02:02 (UTC)

@caelia because iup comes with a motif driver (see ). Is it causing you issues? I guess we could create a split package (e.g. iup-motif) so that it becomes optional.

caelia commented on 2017-11-08 01:43 (UTC)

Why on earth does this package depend on openmotif? Motif has been obsolete for decades; this seems really perverse.