Package Details: luakit-git 1:2.2.r62.g6cac8334-1

Git Clone URL: https://aur.archlinux.org/luakit-git.git (read-only, click to copy)
Package Base: luakit-git
Description: Luakit: now updated for WebKit 2
Upstream URL: https://luakit.github.io
Keywords: browser web webkit
Licenses: GPL3
Conflicts: luakit
Provides: luakit
Submitter: SolarAquarion
Maintainer: SolarAquarion (aidanholm)
Last Packager: SolarAquarion
Votes: 31
Popularity: 0.000035
First Submitted: 2017-02-14 12:45 (UTC)
Last Updated: 2022-04-19 19:16 (UTC)

Latest Comments

1 2 3 Next › Last »

nedludd commented on 2020-06-08 15:31 (UTC) (edited on 2020-06-08 15:35 (UTC) by nedludd)

Build is failing: here's the error:

https://gist.github.com/6cacc55ffdf3628cb336b242ea31d9c5

Edit: looks like it's upstream

henkm commented on 2020-04-26 05:47 (UTC)

First, apologies for posting this here, I don't have a github account. With the latest changes (rev. 33), when I open a link in a new tab (either through my choice or when a link is set to open in a new tab) the new tab opens just empty, without content downloaded. Reverting to rev. 30 solves it for me.

craftyguy commented on 2019-12-11 04:45 (UTC)

Downgrading to webkit2gtk 2.24 seems to require installing icu64 (from AUR) for the build to work. If you don't, it fails at link time.

7415963987456321 commented on 2019-09-17 17:27 (UTC)

For those who are getting bugs with the latest luakit, pages not loading fully until reloaded, high CPU usage and font issues; a temporary fix is to downgrade Webkit to 2.24.

xDShot commented on 2019-01-09 15:07 (UTC)

Please update .SRCINFO as pkgver() naming changed. My AUR helper freaks out and thinks there's newer package version.

t0m5k1 commented on 2017-10-29 10:18 (UTC)

unable to build due to errors with Dependancies: :: Building lua51-say package(s)... ==> Making package: lua51-say 1.3-1 (Sat 28 Oct 18:15:45 BST 2017) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> WARNING: Using existing $srcdir/ tree ==> Removing existing $pkgdir/ directory... ==> Entering fakeroot environment... ==> Starting package()... Warning: skipping dependency checks. Error: Error fetching file: Failed downloading https://github.com/Olivine-Labs/say/archive/v1.3-1.tar.gz - v1.3-1.tar.gz ==> ERROR: A failure occurred in package(). Aborting... :: Building lua51-luassert package(s)... ==> Making package: lua51-luassert 1.7.10-2 (Sat 28 Oct 18:15:46 BST 2017) ==> Checking runtime dependencies... ==> Installing missing dependencies... error: target not found: lua51-say ==> ERROR: 'pacman' failed to install missing dependencies. https://aur.archlinux.org/packages/lua51-luassert/ https://aur.archlinux.org/packages/lua51-say/ Please fix them

aidanholm commented on 2017-09-25 12:00 (UTC)

nightuser: Right, thanks for pointing that out; I'll fix that when the next version is finished, as it seems to be mostly harmless for now

nightuser commented on 2017-09-16 16:07 (UTC)

You shouldn't list `pkg-config` as a dependency, because it's part of `base-devel` group. According to the wiki "Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as dependencies explicitly."

aidanholm commented on 2017-08-27 15:12 (UTC)

t0m5k1: Thanks; fixed!