Package Details: luakit-git 2017.07.26.r0.g5bdc45fa-1

Git Clone URL: https://aur.archlinux.org/luakit-git.git (read-only)
Package Base: luakit-git
Description: Luakit: now updated for WebKit 2
Upstream URL: https://github.com/luakit/luakit
Keywords: browser web webkit
Licenses: GPL3
Conflicts: luakit
Provides: luakit
Submitter: SolarAquarion
Maintainer: SolarAquarion (aidanholm)
Last Packager: aidanholm
Votes: 12
Popularity: 2.625403
First Submitted: 2017-02-14 12:45
Last Updated: 2017-07-25 17:44

Latest Comments

aidanholm commented on 2017-07-23 08:04

zanc: What versions of webkit2gtk and gtk3 do you have?
Edit: also, you can always join us on #luakit on OFTC network; might be quicker to debug by discussing there.
Edit edit: This isn't a luakit bug; I'd guess your packages are out of date. The missing function is defined in /usr/lib/libsoup-2.4.so, which is owned by libsoup (version 2.58.1-1), a dependency of webkit2gtk.

xanc commented on 2017-07-21 21:05

I cannot compile:
cc -o luakit log.o luakit.o luah.o ipc.o web_context.o common/luah.o common/luaserialize.o common/luaclass.o common/ipc.o common/property.o common/luauniq.o common/luautil.o common/util.o common/luayield.o common/luaobject.o common/luajs.o common/clib/regex.o common/clib/luakit.o common/clib/ipc.o common/clib/msg.o common/clib/timer.o clib/request.o clib/sqlite3.o clib/xdg.o clib/unique.o clib/luakit.o clib/download.o clib/ipc.o clib/web_module.o clib/soup.o clib/stylesheet.o clib/widget.o widgets/socket.o widgets/label.o widgets/entry.o widgets/webview.o widgets/common.o widgets/notebook.o widgets/box.o widgets/scrolled.o widgets/paned.o widgets/overlay.o widgets/window.o widgets/spinner.o widgets/drawing_area.o widgets/image.o widgets/eventbox.o common/tokenize.o
/usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libwebkit2gtk-4.0.so: undefined reference to `soup_auth_manager_clear_cached_credentials'
collect2: error: ld returned 1 exit status
make: *** [Makefile:64: luakit] Error 1
==> ERROR: A failure occurred in build().
Aborting...

zappathustra commented on 2017-06-12 08:12

aidanholm: thank you very much, it works.
Really great to see Luakit back on tracks!

kerberos commented on 2017-06-12 07:40

I had to install package pkg-config to get this work. Should it be set as dependency for this package?
Thank you for hard work with luakit, it has been, and still feels to be best microbrowser I've come across. :)

aidanholm commented on 2017-06-11 20:17

zappathustra: Sorry about that; should be fixed now!

zappathustra commented on 2017-06-09 20:05

Trying to build, but it fails with:

[ 0.070061] F: initialize_web_extensions_cb:145: Cannot access luakit extension '/usr/share/luakit/luakit.so': Aucun fichier ou dossier de ce type
make: *** [Makefile:75: apidoc] Error 1

"Aucun fichier de ce type" means "no such file or directory".

aidanholm commented on 2017-05-24 19:42

halocaridina: I'm glad you like it!

halocaridina commented on 2017-05-22 04:20

Appreciate this browser and your efforts in continuing its development!!

aidanholm commented on 2017-04-30 18:47

Please remove options=('!makeflags'); building luakit can be done in parallel.

City-busz commented on 2017-02-15 04:44

Please update the upstream URL to point to the forked repository, and remove libunique from dependencies.

aidanholm commented on 2017-02-14 18:56

Thanks for packaging this; btw help2man isn't needed to build anymore.
Edit: the chmods in package() can be removed too, as `make install` sets them to 0644.