Package Details: lumina-desktop 1.4.0p1-2

Git Clone URL: https://aur.archlinux.org/lumina-desktop.git (read-only)
Package Base: lumina-desktop
Description: A Lightweight QT5 Desktop for FreeBSD
Upstream URL: https://github.com/trueos/lumina
Licenses: BSD
Conflicts: insight-fm, lumina-de-git, lumina-desktop-git
Provides: insight-fm, lumina
Submitter: crossroads1112
Maintainer: cyrevolt
Last Packager: cyrevolt
Votes: 18
Popularity: 1.917435
First Submitted: 2015-05-10 15:59
Last Updated: 2017-12-11 23:05

Dependencies (15)

Required by (0)

Sources (1)

Latest Comments

FredBezies commented on 2017-12-09 06:41

At least there is a newer PKGBUILD. I'm glad I helped a little here :)

1) Please add qt5-svg in depends... At least makedepends one... Or... Bang :(

2) You made a little mistake in my nick : it is FredBezies. Besides of this, no problems :D

pavbaranov commented on 2017-12-06 23:10

@cyrevolt - First it's not neccessary :) Second: I know, that qt5-svg is shown as not needed, but it is. Not needed is lumina.install because all of this job is realised by pacman hooks. Third: I think, that maybe we should add info that using KDE/Qt apps needs another icons like breeze because both icons included in lumina lacks icons required by those apps.

cyrevolt commented on 2017-12-06 22:40

I have just adopted the package, updated the PKGBUILD and added all of you here as contributors. Would you like to be added as a co-maintainer @pavbaranov?

namcap says we don't need qt5-svg: lumina-desktop W: Dependency included and not needed ('qt5-svg')

pavbaranov commented on 2017-12-06 21:17

@colinkeenan - About "install=" - see: https://wiki.archlinux.org/index.php/Pacman#Hooks and https://wiki.archlinux.org/index.php/DeveloperWiki:Pacman_Hooks Yes, problably in my PKGBUILD is missing qt5-svg. As you can see, there is a new version of 1.4.0 with PKGBUILD by FredBezeies I don't think that it's good idea to duplicate DE only because one is only in English and other with translates.

FredBezies commented on 2017-11-30 13:04

Better PKGBUILD working with 1.4.0-p1 : https://pastebin.com/tESHXv5n

Added qt5-svg as a depend.

colinkeenan commented on 2017-11-29 23:18

@pavbaronov, Why did you remove

install="${pkgname%-*}.install"

from the PKGBUILD for your version? All it does is run update-desktop-database -q after installation/upgrade/removal.

Also, if you can't take this one over, maybe you should start another aur package named "lumina-with-translations" or "lumina-localized" or something.

Also, although it's building fine with makepkg, it doesn't build in a clean chroot. There's something missing from this PKGBUILD.

pavbaranov commented on 2017-11-24 17:48

@cyrevolt - yes, of course it's more better. But with my friend from Polish Arch Community - marcin82, we prepared proper version od PKGBUILD. Anyone can find it there: https://pastebin.com/BTdHgfZm
More: http://linux-pavbaranov.blogspot.com/2017/11/lumina-desktop-environment-140.html

cyrevolt commented on 2017-11-23 22:05

I just built and installed 1.4.0, too. I would suggest, in addition to the PKGBUILD provided by pavbaranov, to simply move the manpages just like the /etc diretory:
mv "${pkgdir}"/usr/man "${pkgdir}"/usr/share/man

pavbaranov commented on 2017-11-23 19:31

Ok, I'm not very satified with this PKGBUILD but:
1. it builds current version of Lumina DE,
2. it builds it with translations file,
Everybody should remember that fluxbox is needed as WM for Lumina DE. It's only as optdepends and should be installed for using Lumina.
PKGBUILD: https://pastebin.com/TbE4U4HF

FredBezies commented on 2017-11-22 18:04

Even worse, 1.4.0 was released on November 22nd, 2017.

https://github.com/trueos/lumina/releases/tag/v1.4.0

All comments