Package Details: lutris 0.4.18.1-2

Git Clone URL: https://aur.archlinux.org/lutris.git (read-only)
Package Base: lutris
Description: Open Gaming Platform
Upstream URL: https://lutris.net/
Licenses: GPL3
Submitter: alucryd
Maintainer: Freso (strycore)
Last Packager: Freso
Votes: 119
Popularity: 20.101824
First Submitted: 2013-10-10 14:27
Last Updated: 2018-07-31 05:11

Latest Comments

1 2 3 4 Next › Last »

qark commented on 2018-08-11 11:03

Lutris doesn't depend on dbus-python as of commit https://github.com/lutris/lutris/commit/d48d2410ff11f678cf60a0c1240b58df5713a6ed

straemer commented on 2018-08-08 22:31

@Freso Thanks, that worked for me - command for aura is

aura -A $(pacman -Qoq $(find /usr/lib/python3.6/ -type f) | sort -u)

georgeg commented on 2018-08-08 21:35

The PKGBUILD should be changed to run setup.py with /usr/bin/python specifically.

Freso commented on 2018-08-08 12:24

@Magbed I'd recommend you do something like aurman -S --rebuild (pacman -Qoq (find /usr/lib/python3.6/ -type f) | sort -u) (replacing aurman with whatever AUR helper you're using, if any). This is needed whenever Python (or Ruby or …) is updated to a new "big" version.

mcardillo55 commented on 2018-08-07 07:57

@Magbed Rebuild. Python was upgraded, but lutris is still installed in /usr/lib/python3.6/

Magbed commented on 2018-08-07 07:38

Traceback (most recent call last): File "/usr/bin/lutris", line 33, in <module> from lutris.gui.application import Application ModuleNotFoundError: No module named 'lutris'</module>

Everton commented on 2018-07-31 02:48

Please remove comma in depends(PKG).An error occurs during the update related to this

djazz commented on 2018-06-07 12:07

Please add cabextract as dependency (for winetricks). All other platforms Lutris support has it as a dependency.

raist356 commented on 2018-05-07 17:30

Please add GTK to dependencies.

salsadoom commented on 2018-01-20 18:30

This package is pretty much useless without the browser integration. I'm not sure its this package that's the issue or something that changed in Firefox.. but I found this fix which did work

On firefox, go to about:config. Don’t close the tab just yet
On a new tab, go to lutris’ website > games and open any game page
Switch back to about:config tab and search for network.protocol-handler.expose-all and swtitch it to “False”
tab back to the lutris page and click on the install button, firefox will prompt you if you want to open it with lutris.
Make sure to select the “always use this” option checkbox
tab back to about:config and switch network.protocol-handler.expose-all to true again