Package Details: luxrays-hg 3748+.6941cfd544c4+-1

Git Clone URL: https://aur.archlinux.org/luxrays-hg.git (read-only)
Package Base: luxrays-hg
Description: Accelerate the ray intersection process by using GPUs
Upstream URL: http://www.luxrender.net/
Licenses: GPL
Conflicts: luxrays
Provides: luxrays
Submitter: None
Maintainer: stativ (bartus)
Last Packager: stativ
Votes: 7
Popularity: 0.000000
First Submitted: 2010-09-07 21:57
Last Updated: 2017-03-27 17:47

Dependencies (19)

Required by (1)

Sources (2)

Latest Comments

bartus commented on 2017-03-14 11:04

@stativ Qt4 moc compiler won't build 'luxrender2' gui against boost>1.47.
To fix the issue boost header should be excluded with Q_MOC_RUN.
patch: http://pastebin.com/JL5nDhQ1

bartus commented on 2017-01-10 21:55

@stativ Update python version to 3.6.
Or drop hard coded python version in favour of dynamic one.

_pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")

stativ commented on 2016-11-27 13:39

Thanks guys, it should build fine now!

xoryouyou commented on 2016-11-23 09:30

Im getting the same error as rzizanie.

It looks like the luxrender devs are using a custom fork of embree

http://www.luxrender.net/forum/viewtopic.php?f=22&t=12729

bartus commented on 2016-11-20 20:15

There should be "#branch=default" fragment selector appended to mercurial source, preventing from building unmerged branches with partially incompatible code only because it was updated lately.
/* Now there is "densitygrid" branch "at the top", witch won't build under linux */
Also eos_portable_archive headers should be included in the package for luxrender-hg to build properly.
> add "cp -r deps/eos_portable_archive-v5.1/eos include" at the end of build()

rzizanie commented on 2016-09-14 23:26

got this error here:

bvhembreebuild.cpp:26:40: fatal error: embree2/rtcore_bvh_builder.h: No such file or directory
#include <embree2/rtcore_bvh_builder.h>

seems like embree is missing something

bartus commented on 2016-07-06 10:07

As Arch drop ilmbase-static package luxrays wont build without patching CMakeList.txt for luxcoreui.
Simple hucky patch fixing the issue: http://pastebin.com/2K1wmG33

stativ commented on 2016-03-13 18:38

Thank you for suggestions, currently I've a lot of work, but I'll try to incorporate them soon. I'd like to find a better solution to fix python linking, but the few ones I tried so far didn't work.

bartus commented on 2016-03-13 00:22

You need to disable build of luxrender2 as it needs static ilmbase which is not provided by any package.

bartus commented on 2016-02-17 00:25

'python3.patch' is broken.
Also -lpython3 flag's missing form every link.txt file.
> quick fix: `for file in `grep lboost_python -l -R ` ;do sed -i 's/$/ -lpython3/' $file ; done`

All comments