Package Details: lv2-git 1.17.2.r1257.c0773f8-1

Git Clone URL: https://aur.archlinux.org/lv2-git.git (read-only, click to copy)
Package Base: lv2-git
Description: Plugin standard for audio systems (git version)
Upstream URL: http://lv2plug.in/
Licenses: custom:ISC
Conflicts: lv2, lv2-svn
Provides: lv2, lv2-svn, lv2core
Replaces: lv2core
Submitter: brunogola
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 11
Popularity: 0.000001
First Submitted: 2015-02-23 15:47 (UTC)
Last Updated: 2020-04-15 20:39 (UTC)

Dependencies (16)

Required by (170)

Sources (2)

Latest Comments

SpotlightKid commented on 2020-04-15 20:39 (UTC)

@milk: thanks! fixed.

milkii commented on 2020-04-15 03:14 (UTC)

[69/91] Processing lv2/buf-size/buf-size.ttlTraceback (most recent call last):File "/home/aurbuild/src/lv2-git/src/lv2/lv2specgen/lv2specgen.py", line 34, in <module>import markdownModuleNotFoundError: No module named 'markdown'

milkii commented on 2020-01-31 01:05 (UTC)

I think there's a missing build dep for python-lxml

...
[69/91] Processing lv2/buf-size/buf-size.ttl
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
warning: No Python lxml module found, output may be invalid
...

milkii commented on 2019-12-17 23:43 (UTC)

Can the PKGBUILD version be updated? So as to fix dependency finding.

io7m commented on 2018-04-13 17:04 (UTC)

My mistake. I didn't realize just building the package would automatically use the latest commit, I assumed that the commit was in the PKGBUILD.

io7m commented on 2018-04-13 16:59 (UTC)

Upstream recently made a change that makes the gate plugin work properly in Ardour:

http://lv2plug.in/git/cgit.cgi/lv2.git/commit/?id=728196c9d55100b63b74b2f118bd80d451636a6c

Is there any chance this package could be updated to that version?

brunogola commented on 2015-02-23 15:49 (UTC)

lv2 is now on git, i've uploaded a lv2-git https://aur.archlinux.org/packages/lv2-git/

stativ commented on 2012-04-26 16:26 (UTC)

Merged lv2core-svn into lv2-svn as requested by the maintainer ("lv2core is now bundled in lv2").

speps commented on 2012-04-25 13:18 (UTC)

@looplog lv2core is now bundled in lv2 by upstream.

commented on 2012-04-02 10:00 (UTC)

What is the difference between this and lv2core-svn?

nickl commented on 2012-03-25 16:47 (UTC)

Thanks for the package. Since March 23rd there's no more --experimental option, everything is just always built, and waf will complain if you pass it.

speps commented on 2012-02-20 15:06 (UTC)

@jtxx000 Thanks for reporting. License fixed + added new provides on lv2-{eg-{amp,sampler},message}, and optional dependencies (also not anymore an 'any' package)

commented on 2012-02-19 17:13 (UTC)

The line head -n 16 lv2/ns/$_name/$_name.ttl should be changed to head -n 16 lv2/lv2plug.in/ns/$_name/$_name.ttl

orbisvicis commented on 2011-09-21 02:11 (UTC)

I put the new pkgbuild up @ http://hpaste.org/51592 lots of changes: licenses/conflicts/provides are all automatic I didn't feel like deleting lv2config because it can't hurt to have it.

orbisvicis commented on 2011-09-20 16:20 (UTC)

Still way more convenient than duplicating individualized pkgbuilds for all lv2 plugins... especially since many of them exist only on svn Simplest fix is probably to rename this package to lv2-bundle-svn or lv2-plug-in-svn, then some bash code to automatically get the names and versions of all the extensions

orbisvicis commented on 2011-09-20 15:25 (UTC)

Im not sure its a good idea to package these together, if any package provides *only* lv2core, then any package depending on lv2core wouldn't know to depend on the bundle version, ie it doesnt provide specific dependencies. Besides this bundle doesn't allow individual extension versioning. And the latest version of lv2core is 4.0, not 4.1 (in svn trunk).

speps commented on 2011-03-30 00:24 (UTC)

Updated to build again, since lv2config was rewritten in c. By now I've dropped lv2config, replacing it with a script that creates and includes all the headers symlinks in the binary tarball. If you're replacing lv2core in extra, install the package forcing with pacman -Uf in order to overwrite all the headers generated by lv2config.