Package Details: lv2file-git 0.84.r31.aed7c77-2

Git Clone URL: (read-only)
Package Base: lv2file-git
Description: A command line program to process audio files with LV2 plugins
Upstream URL:
Licenses: GPL3
Conflicts: lv2file
Provides: lv2file
Submitter: SpotlightKid
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 0
Popularity: 0.000000
First Submitted: 2015-04-16 22:46
Last Updated: 2016-02-07 13:44

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

SpotlightKid commented on 2016-02-06 13:31

Thanks for the heads up. I'll look into it tomorrow.

sekret commented on 2016-02-05 23:30

Could you please add 'armv7h' to the arch line? It builds just fine on my Raspberry Pi 2 :)

Most probably it builds just fine for armv6h too (e.g. Raspberry Pi 1), but I cannot confirm...

Also, please add 'lilv' to the depends line, because

1. the build process requires lilv.h, see

==> Starting build()...
cc -c -O3 -Wall -Wextra --std=c99 `pkg-config --cflags argtable2 sndfile lilv-0` -o lv2file.o lv2file.c
Package lilv-0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `lilv-0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lilv-0' found
lv2file.c:5:23: fatal error: lilv/lilv.h: No such file or directory
compilation terminated.
Makefile:9: recipe for target 'lv2file.o' failed
make: *** [lv2file.o] Error 1
==> ERROR: A failure occurred in build().


2. after the build process namcap tells me, that 'libsndfile' is a required dependency.

After all this, namcap also tells me:
lv2file-git W: Referenced library '' is an uninstalled dependency

so it seems to be a dependency ;)