Package Details: lwks-beta 14.0.0.0.92633-1

Git Clone URL: https://aur.archlinux.org/lwks-beta.git (read-only)
Package Base: lwks-beta
Description: Lightworks is a professional video editing suite
Upstream URL: http://www.lwks.com/
Keywords: editor lightworks lwks video
Licenses: custom
Conflicts: lightworks,, lwks
Provides: lightworks
Submitter: stjhimy
Maintainer: marcinn
Last Packager: marcinn
Votes: 12
Popularity: 2.248677
First Submitted: 2014-03-08 13:40
Last Updated: 2017-03-10 21:30

Dependencies (17)

Required by (0)

Sources (2)

Latest Comments

marcinn commented on 2017-02-09 12:51

I've changed versioning scheme of this package due to impossibility of releasing a fixes. Also I've dropped some dependencies looking deprecated/unnecessary. Let me know if you have any problems intalling/upgrading lwks-beta.

itsescde commented on 2017-02-01 17:40

Problem solved with the new version!

marcinn commented on 2017-01-29 12:32

Thanks. There must be some changes in Arch Linux, not in Lightworks. Let me investigate these issues.

itsescde commented on 2017-01-29 12:08

Hey, i got an error with the new release of the beta:
/usr/lib/lightworks/ntcardvt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)
[...]
7e66a9b37000-7e66a9c37000 rwxp 00000000 00:00 0 /usr/bin/lightworks: Zeile 35: 5315 Abgebrochen (Speicherabzug geschrieben) /usr/lib/lightworks/ntcardvt

Then it stops at exporting a clip.

cassia commented on 2017-01-27 02:58

Install or build missing dependencies for lwks-beta:
error: target not found: ffmpeg-compat
please use ffmpeg0.10 instead

electricprism commented on 2016-12-08 03:40

Thanks for this, with the new UI beta I'm excited to give it a go.

marcinn commented on 2016-01-01 22:51

Could you update pkg, please?

pkgver=12.6.C
sha256sums=('d7f57d14834d5bc49337f8a3fff7b4b1fa57b24efa00c1eef609597671e0a8bd')



stratus_ss commented on 2015-12-29 18:54

pkgver=12.6.A
sha256sums=('a214b2cc7922fabfb5828c46c010462af5d437a047d14e0745bed539c43984fe')

Anonymous comment on 2015-07-05 16:26

I tested the suggestion at http://dev.lwks.com/issues/397#note-2 of copying the old openssl and curl (4.41.0-1 and 1.0.1.l-1, respectively) into /usr/lib/lightworks and it worked here. So, that's an option for whoever doesn't want to downgrade these packages just for one application.

Not sure about the RPM package though, unless Fedora 20 (which is on the list of RPM supported distros) uses the new versions of openssl and curl then it will probably be the same thing.

DH4 commented on 2015-07-05 02:14

With latest version 12.5.E they are still building against an older version of openssl. You need to rollback to `openssl-1.0.1.i-1` and `curl-7.39.0-1`. This will get you into Lightworks, keep in mind you will need to downgrade other packages compiled against the newer versions of these packages. I had to rollback to `openssh-6.7p1-1` for example.

I haven't been following Debian/Ubuntu or Fedora too much these days. But I would think Fedora is probably shipping newer packages, and the RPM Lightworks release might be a better package to base this on. That is of course, if Ligthtworks is building the rpm package against the newer packages in Fedora. If it's the same binary blobs wrapped in different packages then of course it doesn't matter. If anyone here is running Fedora on another machine and can verify that would be awesome. I may look into it when/if I get some free time.

Thanks,
Wayne

All comments