Package Details: lwks-beta 12.5.E-1

Git Clone URL: https://aur.archlinux.org/lwks-beta.git (read-only)
Package Base: lwks-beta
Description: Lightworks is a professional video editing suite
Upstream URL: http://www.lwks.com/
Keywords: editor lightworks lwks video
Licenses: custom
Conflicts: lightworks
Provides: lightworks
Submitter: stjhimy
Maintainer: None
Last Packager: CharlesAtum
Votes: 3
Popularity: 0.010684
First Submitted: 2014-03-08 13:40
Last Updated: 2015-07-02 03:33

Latest Comments

marcinn commented on 2016-01-01 22:51

Could you update pkg, please?

pkgver=12.6.C
sha256sums=('d7f57d14834d5bc49337f8a3fff7b4b1fa57b24efa00c1eef609597671e0a8bd')



stratus_ss commented on 2015-12-29 18:54

pkgver=12.6.A
sha256sums=('a214b2cc7922fabfb5828c46c010462af5d437a047d14e0745bed539c43984fe')

CharlesAtum commented on 2015-07-05 16:26

I tested the suggestion at http://dev.lwks.com/issues/397#note-2 of copying the old openssl and curl (4.41.0-1 and 1.0.1.l-1, respectively) into /usr/lib/lightworks and it worked here. So, that's an option for whoever doesn't want to downgrade these packages just for one application.

Not sure about the RPM package though, unless Fedora 20 (which is on the list of RPM supported distros) uses the new versions of openssl and curl then it will probably be the same thing.

DH4 commented on 2015-07-05 02:14

With latest version 12.5.E they are still building against an older version of openssl. You need to rollback to `openssl-1.0.1.i-1` and `curl-7.39.0-1`. This will get you into Lightworks, keep in mind you will need to downgrade other packages compiled against the newer versions of these packages. I had to rollback to `openssh-6.7p1-1` for example.

I haven't been following Debian/Ubuntu or Fedora too much these days. But I would think Fedora is probably shipping newer packages, and the RPM Lightworks release might be a better package to base this on. That is of course, if Ligthtworks is building the rpm package against the newer packages in Fedora. If it's the same binary blobs wrapped in different packages then of course it doesn't matter. If anyone here is running Fedora on another machine and can verify that would be awesome. I may look into it when/if I get some free time.

Thanks,
Wayne

DH4 commented on 2015-07-05 02:13

With latest version 12.5.E they are still building against an older version of openssl. You need to rollback to `openssl-1.0.1.i-1` and `curl-7.39.0-1`. This will get you into Lightworks, keep in mind you will need to downgrade other packages compiled against the newer versions of these packages. I had to rollback to `openssh-6.7p1-1` for example.

I haven't been following Debian/Ubuntu or Fedora too much these days. But I would think Fedora is probably shipping newer packages, and the RPM Lightworks release might be a better package to base this on. That is of course, if Ligthtworks is building the rpm package against the newer packages in Fedora. If it's the same binary blobs wraped in diffrent package formats then of course it doesn't matter. If anyone here is running Fedora on another machine and can verify that would be awesome. I may look into it when/if I get some free time.

Thanks,
Wayne

DH4 commented on 2015-07-05 02:12

With latest version 12.5.E they are still building against an older version of openssl. You need to rollback to `openssl-1.0.1.i-1` and `curl-7.39.0-1`. This will get you into Lightworks, keep in mind you will need to downgrade other packages compiled against the newer versions of these packages. I had to rollback to `openssh-6.7p1-1` for example.

I haven't been following Debian/Ubuntu or Fedora too much these days. But I would think Fedora is probably shipping newer packages, and the RPM Lightworks release might be a better package to base this on. That is of course, if Ligthtworks is building the rpm package against the newer packages in Fedora. If anyone here is running Fedora on another machine and can verify that would be awesome. I may look into it when/if I get some free time.

Thanks,
Wayne

DH4 commented on 2015-07-05 02:06

With latest version 12.5.E they are still building against an older version of openssl. You need to rollback to `openssl-1.0.1.i-1` and `curl-7.39.0-1`. This will get you into Lightworks, keep in mind you will need to downgrade other packages compiled against the newer versions of these packages. I had to rollback to `openssh-6.7p1-1` for example.

I haven't been following Debian/Ubuntu or Fedora too much these days. But I would think Fedora is probably shipping newer packages, and the RPM Lightworks release might be a better package to base this on. If anyone here is running Fedora on another machine and can verify that would be awesome. I may look into when/if I get some free time.

Thanks,
Wayne

CharlesAtum commented on 2015-07-02 12:53

Backtrace from coredump:
Core was generated by `/usr/lib/lightworks/ntcardvt'.
Program terminated with signal SIGABRT, Aborted.
#0 0x00007f7ac6363528 in raise () from /usr/lib/libc.so.6
(gdb) bt
#0 0x00007f7ac6363528 in raise () from /usr/lib/libc.so.6
#1 0x00007f7ac636493a in abort () from /usr/lib/libc.so.6
#2 0x00007f7ac6977b3d in __gnu_cxx::__verbose_terminate_handler ()
at /build/gcc-multilib/src/gcc-5-20150623/libstdc++-v3/libsupc++/vterminate.cc:95
#3 0x00007f7ac6975996 in __cxxabiv1::__terminate (handler=<optimized out>)
at /build/gcc-multilib/src/gcc-5-20150623/libstdc++-v3/libsupc++/eh_terminate.cc:47
#4 0x00007f7ac69759e1 in std::terminate () at /build/gcc-multilib/src/gcc-5-20150623/libstdc++-v3/libsupc++/eh_terminate.cc:57
#5 0x00007f7ac697651f in __cxxabiv1::__cxa_pure_virtual () at /build/gcc-multilib/src/gcc-5-20150623/libstdc++-v3/libsupc++/pure.cc:50
#6 0x00007f7acd26cd20 in OpenGLTextureCache::insert(OpenGLImage const&, TextureDetails const&) () from /usr/lib/lightworks/libOS.so
#7 0x00007f7acd2603d5 in OpenGLImage::~OpenGLImage() () from /usr/lib/lightworks/libOS.so
#8 0x00007f7acd260699 in OpenGLImage::~OpenGLImage() () from /usr/lib/lightworks/libOS.so
#9 0x00007f7acd26f456 in OpenGLUtils::~OpenGLUtils() () from /usr/lib/lightworks/libOS.so
#10 0x00007f7ac6365e78 in __run_exit_handlers () from /usr/lib/libc.so.6
#11 0x00007f7ac6365ec5 in exit () from /usr/lib/libc.so.6
#12 0x00007f7acc27a4e3 in postSplatShutdown() () from /usr/lib/lightworks/libmisc.so
#13 0x00007f7acc27a60c in ole_splat(char const*) () from /usr/lib/lightworks/libmisc.so
#14 0x00007f7acd281437 in Thread::protectedExecute(iThread::eExecRC (*)(void*), void*, void (*)(iThread::Exception const&)) ()
from /usr/lib/lightworks/libOS.so
#15 0x00007f7acc2c0039 in protectedExecute(iThread::eExecRC (*)(void*), void*) () from /usr/lib/lightworks/libmisc.so
#16 0x0000000000447342 in main ()

Arbite commented on 2015-04-05 20:04

12.0.3.L is out. Please update to latest. Lots of fixes

xlegs commented on 2015-01-19 18:09

pkgver=12.0.3.A
sha256sums=('0fd2d61e60d0547dc2ff12d334ac102cf777ade6b943016c05b72836cda4e245')

CharlesAtum commented on 2014-10-01 16:36

Actually, after some thought, I think I will just bump this to the same version as the stable.
So, you can still keep using this package if you want to test the Betas.

CharlesAtum commented on 2014-10-01 16:07

Sorry, guys. There's no current beta. Please switch to the lwks package in the mean time.

stjhimy commented on 2014-09-30 12:34

Guys, sorry the delay, I'm having to travel a lot because of my work.
I will disown the package right now, hope you guys can take a better care of it.
Thanks.

maxp commented on 2014-09-20 01:34

pkgver=12.0.RC2
sha256sums=( '4afdc730d2e07f9657dfdbb05e8982051787e7945803266f955494311609746c')

spjoe commented on 2014-08-30 07:02

pkgver=12.0.M
sha256sums=('2fbee5fb069814f9531ef971925a15bcfa7ad277a323f29079b019bc6fdf58e2')

spjoe commented on 2014-08-29 10:46

pkgver=12.0.L
sha256sums=('80f8f99ff2ed97c19c1200135b2aa87ededb076f96cc45c4528a165d223d16aa')

PieterDeBruijn commented on 2014-08-10 12:21

Beta 12.0i now available:
http://www.lwks.com/index.php?option=com_kunena&func=view&catid=19&id=76430&Itemid=81