Package Details: lwks 14.5.0-1

Git Clone URL: https://aur.archlinux.org/lwks.git (read-only)
Package Base: lwks
Description: Lightworks is a professional video editing suite
Upstream URL: http://www.lwks.com/
Keywords: editor lightworks lwks video
Licenses: custom
Conflicts: lightworks, lwks-beta
Provides: lightworks
Submitter: CYB3R
Maintainer: marcinn
Last Packager: marcinn
Votes: 125
Popularity: 0.715443
First Submitted: 2013-01-30 14:17
Last Updated: 2018-10-18 12:04

Dependencies (18)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

marcinn commented on 2017-06-30 12:59

Thanks. I've tried without openssl-1.0-compat preloaded and I've got a crash. So I need some time to investigate this and check whole installation on clean Arch.

parkerlreed commented on 2017-06-30 12:41

Here's the lists link showing where the main openssl updated to work with the older references https://lists.archlinux.org/pipermail/aur-requests/2017-June/017669.html

parkerlreed commented on 2017-06-30 12:40

@marcinn First time I never got a login prompt. Cleared those files, relaunched, created an account, signed in and I'm at the main project menu. Seems to be working fine. https://my.mixtape.moe/ioekuc.png

marcinn commented on 2017-06-30 12:33

Does anybody know better workaround than compiling openssl-1.0 during lwks build and putting openssl-1.0 files somewhere inside /usr/lib/lightworks ?

Does anybody know why libopenssl-1.0-compat was removed?

marcinn commented on 2017-06-30 12:31

@parkerlreed

I'm not so sure. Can you move out (but backup first) ~/Lightworks/license.* files to force login box reappear, and try to run the software again? For my knoweldge it will crash with segfault without openssl-1.0 preloaded.

parkerlreed commented on 2017-06-30 12:27

openssl was fixed to work with the older 1.0 references. The PKGBUILD needs to be updated to remove the LD_PRELOAD from the last line of the lightworks launch script. Runs fine after removing the LD_PRELOAD.

TeddyDD commented on 2017-06-26 08:51

It seems that this package depends on libopenssl-1.0-compat that is no longer available in AUR.

Bunker commented on 2017-05-24 08:48

Disregard my previous update, when updating to the latest kernel it works again. Sorry about that.

Bunker commented on 2017-05-24 08:28

We have another incompatability problem.

Anybody an solution for the following error when starting ligthworks?

/usr/lib/lightworks/ntcardvt: /usr/lib/libssl-compat.so.1.0.0: no version information available (required by /usr/lib/libcurl-openssl-1.0.so)

nucularJohn commented on 2017-05-05 23:09

@marcinn @lucasheringer Great! :D