Package Details: lwks 14.5.0-1

Git Clone URL: https://aur.archlinux.org/lwks.git (read-only)
Package Base: lwks
Description: Lightworks is a professional video editing suite
Upstream URL: http://www.lwks.com/
Keywords: editor lightworks lwks video
Licenses: custom
Conflicts: lightworks, lwks-beta
Provides: lightworks
Submitter: CYB3R
Maintainer: marcinn
Last Packager: marcinn
Votes: 125
Popularity: 0.727590
First Submitted: 2013-01-30 14:17
Last Updated: 2018-10-18 12:04

Dependencies (18)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

marcinn commented on 2017-05-05 21:53

@nucularJohn: Thank you. Now the package contains a patch.

lucasheringer commented on 2017-05-05 02:27

@nucularJohn you are the best, it worked! Many thanks!

nucularJohn commented on 2017-05-04 20:41

> /usr/bin/lightworks: line 35: 15481 Aborted (core dumped) /usr/lib/lightworks/ntcardvt

I had this problem. Fixed it creating `/usr/local/bin/lightworks` with:

#!/bin/bash
export LD_PRELOAD="libcrypto-compat.so.1.0.0 libssl-compat.so.1.0.0 libcurl-openssl-1.0.so"
/usr/bin/lightworks

kanadian commented on 2017-05-01 08:59

I had the very same problem. Must be something related to this version for ubuntu. I made it work with fedora package and compat-openssl10-1.0.2j-6.fc26 RPM for x86_64. However I did not check it working on a project yet. So maybe crashing at any time.. I know this is not a clean solution but it works for now.

lucasheringer commented on 2017-04-30 22:53

Thanks @marcinn but after removed extra/openssl-1.0 I started to have the same error as @Ede_Vau
/usr/lib/lightworks/ntcardvt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)
/usr/bin/lightworks: line 35: 15481 Aborted (core dumped) /usr/lib/lightworks/ntcardvt

Ede_Vau commented on 2017-04-30 22:13

lightworks starts with loading, but after a moment it is crashing down.

123@xxx:~$ env "LD_PRELOAD=/usr/lib/openssl-1.0-compat/libssl.so /usr/lib/openssl-1.0-compat/libcrypto.so" /usr/bin/lightworks
/usr/lib/lightworks/ntcardvt: /usr/lib/openssl-1.0-compat/libcrypto.so: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)
/usr/bin/lightworks: Zeile 35: 7883 Abgebrochen (Speicherabzug geschrieben) /usr/lib/lightworks/ntcardvt

marcinn commented on 2017-04-30 09:43

I've added libopenssl-1.0-compat dependency recently. It works for me (I've tested this also on clean Arch install with XFCE). Lightworks is starting from shell and from application menu.

Openssl from extra/openssl-1.0 does not work for me (ends with 'OPENSSL_1.0.0' not found error).

But I see that openssl-1.0 is conflicting with libopenssl-1.0-compat. In that case I'll search for solution based on openssl-1.0, but until it happens I can only suggest switching to libopenssl-1.0-compat.

lucasheringer commented on 2017-04-30 02:45

Same here, anyone able to solve this?

/usr/lib/lightworks/ntcardvt: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/lib/lightworks/libOSPrivate.so)

pmcnr commented on 2017-04-28 04:57

With:

env "LD_PRELOAD=/usr/lib/openssl-1.0-compat/libssl.so /usr/lib/openssl-1.0-compat/libcrypto.so" /usr/bin/lightworks

I get:

/usr/lib/lightworks/ntcardvt: /usr/lib/openssl-1.0-compat/libcrypto.so: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)

I haven't had any success with other variants of pre-loading openssl-1.0.

Anonymous comment on 2017-04-27 10:48

need to change Exec in lightworks.desktop

Exec=env "LD_PRELOAD=/usr/lib/openssl-1.0-compat/libssl.so /usr/lib/openssl-1.0-compat/libcrypto.so" /usr/bin/lightworks