Package Details: lximage-qt 0.5.0-3

Git Clone URL: (read-only)
Package Base: lximage-qt
Description: The LXQt image viewer
Upstream URL:
Licenses: GPL2
Groups: lxqt
Submitter: Diego
Maintainer: johnnybash
Last Packager: johnnybash
Votes: 41
Popularity: 5.065529
First Submitted: 2013-07-04 08:52
Last Updated: 2016-10-21 17:47

Latest Comments

Bermond commented on 2016-10-21 16:59

'git' should be added to 'makedepends'. Otherwise you get the following error:

CMake Error at /usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find Git (missing: GIT_EXECUTABLE)
Call Stack (most recent call first):
/usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.6/Modules/FindGit.cmake:83 (find_package_handle_standard_args)
/usr/share/cmake/lxqt/modules/LXQtTranslateTs.cmake:165 (find_package)
src/CMakeLists.txt:43 (lxqt_translate_ts)

-- Configuring incomplete, errors occurred!

pmattern commented on 2016-10-17 19:01

> thought it would work without further adjustment, cause both are installed on my system anyway...
Yeah, common pitfall. On desktop systems some component pulling those two packages is preexisting most of the time. But to ensure the hooks are working they should be added as dependency nevertheless, much as they are right now.

johnnybash commented on 2016-10-17 15:56

ah ok,
thought it would work without further adjustment, cause both are installed on my system anyway...
added both as dependencies

sorry for this circumstances, never used pacman hooks before.

and thanks for your help ;)

pmattern commented on 2016-10-16 20:18

In order to replace the former install script by pacman hooks you have to make the packages providing the hooks a dependency. Namely these are desktop-file-utils (binary update-desktop-database to include MIME Types covered by LXImage-Qt into mimeinfo.cache) and gtk-update-icon-cache (binary named the same to update icon cache).

pmattern commented on 2016-10-10 12:25

Dependency pcmanfm-qt should be replaced with libfm-qt as it's more lean but sufficient.
Instead of the install script pacman hooks should be used.
It would be good to verify the source archive with the GPG key that's now available.

jleclanche commented on 2016-10-09 12:06

I have disowned the package for the time being. Once it's more full-featured it'll go in [community] directly.

AlexTalker commented on 2016-10-09 11:54

linka commented on 2016-10-06 21:56

An update is required, because now libfm-qt5 is just called libfm-qt. A simple symlink made it work (I had already compiled the package), but someone needs to change the dependencies in the source.

johnnybash commented on 2016-10-01 12:16

Building and installing Version 0.5.0 works just fine.
Just replace Version Number and sha256sum.

isseigx commented on 2016-06-25 17:48

The package is updated, this link works:
the sha265sum is the same

All comments